php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6053 commenting with // and ?>
Submitted: 2000-08-09 22:25 UTC Modified: 2000-08-09 22:34 UTC
From: wico at cnh dot nl Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0 Latest CVS (09/08/2000) OS: linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: wico at cnh dot nl
New email:
PHP Version: OS:

 

 [2000-08-09 22:25 UTC] wico at cnh dot nl
hiya

i ran into some strange behaviour of //
i commented this line with //

$data = preg_replace("'(<A\s.*?>.*?)?([a-z0-9_.=-]+@(?:[a-z0-9-]+\.)+(?:[a-z]{2,3}))((?(1).*?</A>))'imeS" , 'Html_Make_Email_Links_Helper("\\1", "\\2", "\\3");' , &$data);

and i got a parse error (because of the ?> inside of the regex)
but is commented out and it is betweern quotes so i shouldn't complain

when i commented it out with /**/ theres no problem

greetz,

Wico

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-09 22:34 UTC] stas@php.net
This si by design. Use /* */.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Sep 22 09:03:38 2021 UTC