php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #60507 The else part will never execute
Submitted: 2011-12-13 02:46 UTC Modified: 2012-11-15 09:23 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: sid2089 at gmail dot com Assigned:
Status: Not a bug Package: Filesystem function related
PHP Version: Irrelevant OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sid2089 at gmail dot com
New email:
PHP Version: OS:

 

 [2011-12-13 02:46 UTC] sid2089 at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/function.flock#refsect1-function.flock-
examples
---

In example 1, the else part will never execute as the lock will block


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-11-15 09:23 UTC] krakjoe@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

As the documentation states; some file systems do not support file locking, so the 
return value should in fact be checked, and could in fact be false.
 [2012-11-15 09:23 UTC] krakjoe@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Aug 09 17:01:23 2020 UTC