php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60481 Can't send cookies when retrieving WSDL with SoapClient
Submitted: 2011-12-09 14:38 UTC Modified: 2021-02-12 15:55 UTC
Votes:3
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: jille at hexon dot cx Assigned: cmb (profile)
Status: Not a bug Package: SOAP related
PHP Version: 5.3.8 OS: n/a
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
18 - 4 = ?
Subscribe to this entry?

 
 [2011-12-09 14:38 UTC] jille at hexon dot cx
Description:
------------
When you construct a SoapClient it immediatly fetches the WSDL, before you have the chance to set cookies. Our setup requires some cookie to be sent when fetching the WSDL which is currently impossible.

It should be possible to give cookies to the SoapClient constructor which should be sent along with the request for the WSDL.

Test script:
---------------
$soap = new SoapClient('http://webservice/wsdl', array('username' => 'x', 'password' => 'y'));
$soap->__setCookie('extra_thing', 'z');


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-12-09 14:50 UTC] jille at hexon dot cx
We could also add cookies to stream-contexts (proposed it in https://bugs.php.net/bug.php?id=60482)
 [2021-02-12 15:55 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2021-02-12 15:55 UTC] cmb@php.net
You can add cookies by using a stream context.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 05:01:28 2024 UTC