php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #60470 PEAR Folder not included in PHP 5.3.8 VC9
Submitted: 2011-12-08 12:15 UTC Modified: 2016-07-03 05:58 UTC
Votes:9
Avg. Score:4.8 ± 0.4
Reproduced:8 of 8 (100.0%)
Same Version:2 (25.0%)
Same OS:8 (100.0%)
From: JBlond at gmail dot com Assigned:
Status: Not a bug Package: Windows Installer
PHP Version: 5.3.8 OS: Windows
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: JBlond at gmail dot com
New email:
PHP Version: OS:

 

 [2011-12-08 12:15 UTC] JBlond at gmail dot com
Description:
------------
Discussion see 
http://news.php.net/php.internals.win/838
and 
http://news.php.net/php.internals.win/840

Test script:
---------------
n/a

Expected result:
----------------
The PEAR Folder should be included into the zip file

Actual result:
--------------
PEAR folder isn't in the zip

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-05-27 06:29 UTC] bichinhoverde at spwinternet dot com dot br
Both the 5.3.13 and 5.4.3 zip packages lack the PEAR files. 5.2.17 is fine.
For 5.3.13, the workaround would be to use the msi installer instead of the zip package. It has the PEAR files.
Unfortunatelly, 5.4.3 doesn't have the msi intaller.
 [2012-10-04 09:07 UTC] php at integritec dot co dot uk
It would be really helpful to have guidance for those who have already installed 
PHP - "use the MSI installer" isn't ideal if we've already got the whole 
technology stack in place.
Can PEAR files be dropped in from another location / install?
 [2015-06-09 18:45 UTC] cmb@php.net
-Assigned To: +Assigned To: pajoye
 [2015-06-09 18:45 UTC] cmb@php.net
How to install the PEAR package manager is explained in the PEAR
manual.[1]

I have some doubts about the value of adding the PEAR installer in
the Windows downloads of PHP now, but I'm assigning to Pierre as
requested[2].

[1] <https://pear.php.net/manual/en/installation.getting.php>
[2] <http://news.php.net/php.internals.win/841>
 [2016-07-03 05:58 UTC] pajoye@php.net
-Status: Assigned +Status: Not a bug -Assigned To: pajoye +Assigned To:
 [2016-07-03 05:58 UTC] pajoye@php.net
We do not support the installer anymore
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 10 08:05:46 2022 UTC