php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60461 Wrong value outputted
Submitted: 2011-12-07 18:02 UTC Modified: 2011-12-08 01:04 UTC
From: kodfish01 at yahoo dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5.4.0RC2 OS: windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kodfish01 at yahoo dot com
New email:
PHP Version: OS:

 

 [2011-12-07 18:02 UTC] kodfish01 at yahoo dot com
Description:
------------
---
From manual page: http://www.php.net/function.floor#refsect1-function.floor-
returnvalues
---
$diameter = 0.474;   //0utput should be 0.5 but floor function rounds the 2 down 
to 1?


$us_ring_size = floor($diameter - 0.458)/0.008) * 0.25;



Expected result:
----------------
0.5

Actual result:
--------------
0.25

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-12-08 01:04 UTC] yohgaki@php.net
-Status: Open +Status: Bogus
 [2011-12-08 01:04 UTC] yohgaki@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed May 29 08:01:32 2024 UTC