php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60438 wrong version number in php_gearman.h
Submitted: 2011-12-04 01:05 UTC Modified: 2011-12-05 16:44 UTC
From: omega13a at yahoo dot com Assigned: hradtke (profile)
Status: Closed Package: gearman (PECL)
PHP Version: 5.3.8 OS: Fedora 14
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: omega13a at yahoo dot com
New email:
PHP Version: OS:

 

 [2011-12-04 01:05 UTC] omega13a at yahoo dot com
Description:
------------
I was attempting to rebuild the php-pecl-gearman package using the latest 
version of the gearman package (1.0.0). This is the result:

Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.cadtyh
+ umask 022
+ cd /home/omega13a/rpmbuild/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ cd /home/omega13a/rpmbuild/BUILD
+ rm -rf php-pecl-gearman-1.0.0
+ /bin/mkdir -p php-pecl-gearman-1.0.0
+ cd php-pecl-gearman-1.0.0
+ /usr/bin/gzip -dc /home/omega13a/rpmbuild/SOURCES/gearman-1.0.0.tgz
+ /bin/tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
++ sed -n '/#define PHP_GEARMAN_VERSION/{s/.* "//;s/".*$//;p}' gearman-
1.0.0/php_gearman.h
+ extver=0.8.0
+ test x0.8.0 '!=' x1.0.0
+ : Error: Upstream version is 0.8.0, expecting 1.0.0.
+ exit 1
error: Bad exit status from /var/tmp/rpm-tmp.cadtyh (%prep)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.cadtyh (%prep)

looking at the source code, it was obvious the problem was caused by 
PHP_GEARMAN_VERSION not being set to the correct version number. Its a minor 
thing but I thought you should know.

Expected result:
----------------
able to build the RPM without any errors.


Patches

corrected-version (last revision 2011-12-04 01:06 UTC by omega13a at yahoo dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-12-05 16:36 UTC] hradtke@php.net
Automatic comment from SVN on behalf of hradtke
Revision: http://svn.php.net/viewvc/?view=revision&revision=320441
Log: Fixed PECL Bug #60438 (wrong version number in php_gearman.h)
 [2011-12-05 16:44 UTC] hradtke@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: hradtke
 [2011-12-05 16:44 UTC] hradtke@php.net
Thank you for the feedback. I just released gearman-1.0.1 to fix this.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jul 10 03:01:26 2020 UTC