php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60378 Can't do pam_auth
Submitted: 2011-11-24 21:58 UTC Modified: 2017-04-01 21:06 UTC
Votes:4
Avg. Score:4.2 ± 0.8
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:1 (33.3%)
From: vyedmic at gmail dot com Assigned:
Status: Wont fix Package: PAM (PECL)
PHP Version: 5.3.8 OS: Gentoo
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vyedmic at gmail dot com
New email:
PHP Version: OS:

 

 [2011-11-24 21:58 UTC] vyedmic at gmail dot com
Description:
------------
Trying to do pam_auth and with no success. It used to work fine with previous php version, which was some 5.2. I am a little bit weary of allowing apache access to shadow and again, it used to work fine. What else has changed? Sorry to be reporting it this late but users don't change their password everyday.

Test script:
---------------
<?php
 if (pam_auth($usr, $pswd, $error, false)) {
     echo "Succesfully authorised $usr";
  }
 else {
     echo $error;
  }
?>

Expected result:
----------------
Succesfully authorised user

Actual result:
--------------
bool(false) AUthentication failure (in pam_authenticate)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 21:06 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 21:06 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2009, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Dec 05 15:03:33 2021 UTC