php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #60335 Regarding includeing external file
Submitted: 2011-11-19 07:40 UTC Modified: 2011-11-19 07:56 UTC
From: krmanish260 at gmail dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 5.3.8 OS: ubuntu11.4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: krmanish260 at gmail dot com
New email:
PHP Version: OS:

 

 [2011-11-19 07:40 UTC] krmanish260 at gmail dot com
Description:
------------
Hi all,
 i have tried to send parameter through the include file. 


Test script:
---------------
example: include'footer.php/'.array('name'=>$name);
and include'footer.php/'.$name;

but showing errror as
failed to open stream: No such file or directory and
include(): Failed opening 'include/footer.php/Array' for inclusion (include_path='.:/usr/share/php:/usr/share/pear')


Expected result:
----------------
Here I want to pass a value to the footer.php.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-11-19 07:56 UTC] laruence@php.net
-Status: Open +Status: Bogus
 [2011-11-19 07:56 UTC] laruence@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

$footer = "this value can be accessed in footer.php";
include "footer.php";

footer.php:
<?php
  echo $footer;
?>
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jul 22 09:01:28 2024 UTC