php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60331 php 5.4 + zts build fails
Submitted: 2011-11-18 17:05 UTC Modified: 2012-01-28 04:33 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: fedora at famillecollet dot com Assigned: rasmus (profile)
Status: Closed Package: mailparse (PECL)
PHP Version: 5.4.0RC1 OS: GNU/Linux (Fedora 15)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fedora at famillecollet dot com
New email:
PHP Version: OS:

 

 [2011-11-18 17:05 UTC] fedora at famillecollet dot com
Description:
------------
Building this extension against PHP 5.4.0RC1 fails.

function_entry should be replace by zend_function_entry

In ZTS mode, zome tsrm_ls are missing, adding TSRMLS_* macro solves this issue.


Please consider attached patch

Note : build and load fine.
All tests succed.


Expected result:
----------------
=====================================================================
PHP         : /usr/bin/php 
PHP_SAPI    : cli
PHP_VERSION : 5.4.0RC2-dev
ZEND_VERSION: 2.4.0
PHP_OS      : Linux - Linux lovelock.famillecollet.com 2.6.41.1-1.fc15.x86_64 #1 SMP Fri Nov 11 21:36:28 UTC 2011 x86_64
INI actual  : /dev/shm/php-pecl-mailparse-2.1.5/mailparse-2.1.5
More .INIs  :  
CWD         : /dev/shm/php-pecl-mailparse-2.1.5/mailparse-2.1.5
Extra dirs  : 
VALGRIND    : Not used
=====================================================================
TIME START 2011-11-18 18:00:37
=====================================================================
PASS Check for mailparse presence [tests/001.phpt] 
PASS Check stream encoding [tests/002.phpt] 
PASS Check handling of multiple To headers [tests/003.phpt] 
PASS Check uudecode_all [tests/004.phpt] 
PASS Check quoted-printable encoding generates S/MIME safe content [tests/005.phpt] 
PASS Check extract_part_file [tests/006.phpt] 
PASS Check RFC822 Conformance [tests/007.phpt] 
PASS OO API Segfault when opening a file is not possible [tests/008.phpt] 
PASS Multiple UUE attachments not recognized [tests/009.phpt] 
PASS Multiple headers not parsed into arra bug #6862 [tests/010.phpt] 
PASS Parse messages in testdata dir [tests/parse_test_messages.phpt] 
=====================================================================
TIME END 2011-11-18 18:00:37

=====================================================================
TEST RESULT SUMMARY
---------------------------------------------------------------------
Exts skipped    :    0
Exts tested     :   31
---------------------------------------------------------------------

Number of tests :   11                11
Tests skipped   :    0 (  0.0%) --------
Tests warned    :    0 (  0.0%) (  0.0%)
Tests failed    :    0 (  0.0%) (  0.0%)
Expected fail   :    0 (  0.0%) (  0.0%)
Tests passed    :   11 (100.0%) (100.0%)
---------------------------------------------------------------------
Time taken      :    0 seconds
=====================================================================



Patches

php54.patch (last revision 2011-11-18 17:05 UTC by fedora at famillecollet dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-01-28 04:33 UTC] rasmus@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: rasmus
 [2012-01-28 04:33 UTC] rasmus@php.net
Looks like someone fixed this
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Mar 25 20:01:26 2019 UTC