php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #60127 Error message received
Submitted: 2011-10-25 07:27 UTC Modified: 2011-10-25 08:08 UTC
From: tilewakolt at gmail dot com Assigned:
Status: Not a bug Package: Testing related
PHP Version: Irrelevant OS: Windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tilewakolt at gmail dot com
New email:
PHP Version: OS:

 

 [2011-10-25 07:27 UTC] tilewakolt at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/faq.installation
---
I have configured the apache and php and tested. I have just added the MySQL database but could not connect to the database. The message I receive after opening my browser to connect is "Fatal error: Call to undefined function mysql_connect() in C:\mydocs\test.php on line 13". Line 13 is where the connection is suppose to be made as follows:
$link = mysql_connect($dbServer, $dbUser, $dbPass) or die("Could not connect to server");
    echo "<p>Connected successfully</p>";
The message i was expecting is "Connect successfully" but received
"Fatal error: Call to undefined function mysql_connect() in C:\mydocs\test.php on line 13".
Kindly help me out. 
 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-10-25 08:08 UTC] laruence@php.net
-Status: Open +Status: Bogus
 [2011-10-25 08:08 UTC] laruence@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

uncomment  extension=mysql.dll in php.ini
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat May 08 05:01:23 2021 UTC