php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59978 can not timeout
Submitted: 2011-09-30 11:48 UTC Modified: 2017-04-01 21:27 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: goodook at 163 dot com Assigned:
Status: Wont fix Package: PHPScript (PECL)
PHP Version: 5.2.6 OS: windows xp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: goodook at 163 dot com
New email:
PHP Version: OS:

 

 [2011-09-30 11:48 UTC] goodook at 163 dot com
Description:
------------
after set ScriptControl  Timeout,  php script run a long time, and not stop/timeout.

Reproduce code:
---------------
 ScriptControl1.Language = "PHPscript"
 ScriptControl1.AddObject "f", Form1
 ScriptControl1.Timeout = 10 ScriptControl1.AddCode " set_time_limit(10); for($i=0; $i<30; $i++){sleep(2);}"

the script not timeout.

Expected result:
----------------
timeout

Actual result:
--------------
not timeout.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 21:27 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 21:27 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2009, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Dec 02 23:01:23 2020 UTC