php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59954 imagick fully broken on Debian Squeeze
Submitted: 2011-09-16 15:39 UTC Modified: 2015-01-18 04:22 UTC
From: adrian at swiftwill dot com Assigned: mkoppanen (profile)
Status: No Feedback Package: imagick (PECL)
PHP Version: 5.3.6 OS: GNU/Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
16 + 44 = ?
Subscribe to this entry?

 
 [2011-09-16 15:39 UTC] adrian at swiftwill dot com
Description:
------------
Hello, 
I've been building imagick 2.3.0, 3.0.1 and 3.1.0RC1 against ImageMagick 6.6.0.4 on Debian Squeeze, with PHP 5.3.6. 

All the modules build fine, no problem there. But on enabling the module in php.ini the following happens: 

# php --modules
php: unable to initialize module loader `(' @ fatal/module.c/InitializeModuleList/879.
<PHP hang>


Google searches revealed nothing but the problem originating in a function of ImageMagick it self: 
http://trac.imagemagick.org/browser/ImageMagick/trunk/magick/module.c?rev=829#L848



Could you help me understand? Thank you.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-09-16 15:45 UTC] at php dot net
Hi,

looks like an issue with calling lt_dlinit from ImageMagick. 
You could setup a breakpoint and see what error code is 
returned.

In any case looks more of a possible debian squeeze issue 
rather than Imagick issue.
 [2013-12-03 11:31 UTC] mike@php.net
-Assigned To: +Assigned To: mkoppanen
 [2015-01-05 02:56 UTC] danack@php.net
-Status: Assigned +Status: Feedback
 [2015-01-05 02:56 UTC] danack@php.net
If this is still an issue, please add some details of how to reproduce.
 [2015-01-18 04:22 UTC] pecl-dev at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Sep 28 19:03:36 2021 UTC