php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59952 configure: error: wrong libsphinxclient version or lib not found
Submitted: 2011-09-14 17:37 UTC Modified: 2011-09-18 02:34 UTC
From: fuxa_kos at unihost dot cz Assigned:
Status: Not a bug Package: sphinx (PECL)
PHP Version: 5.3.6 OS: CentOS 5
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: fuxa_kos at unihost dot cz
New email:
PHP Version: OS:

 

 [2011-09-14 17:37 UTC] fuxa_kos at unihost dot cz
Description:
------------
My PHP version is 5.3.8, but isn't in "PHP version" select/option!
But same error with 5.3.6.

configure returns error
checking for libsphinxclient headers in /usr/share/sphinx/api/libsphinxclient/... found
checking for sphinx_create in -lsphinxclient... no
configure: error: wrong libsphinxclient version or lib not found

full output from configure attached


system is up2date CentOS 5.6
uname --all
Linux iduna 2.6.18-238.12.1.el5 #1 SMP Tue May 31 13:22:04 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux


sphinx (actualy Generally recommended release) version
rpm -qi `rpm -qf /usr/share/sphinx/api/libsphinxclient/sphinxclient.h`
Name        : sphinx                       Relocations: (not relocatable)
Version     : 2.0.1                             Vendor: Sphinx Technologies Inc.
Release     : 1.el5                         Build Date: Fri 22 Apr 2011 04:57:46 AM CEST
Install Date: Wed 11 May 2011 12:49:56 PM CEST      Build Host: rhel54x64
Group       : Applications/Text             Source RPM: sphinx-2.0.1-1.el5.src.rpm
Size        : 13850610                         License: GPLv2
Signature   : (none)
Packager    : Sphinx Technologies Inc.
URL         : http://sphinxsearch.com
Summary     : Sphinx full-text search server

because configure looking for 
/usr/share/sphinx/api/libsphinxclient/include/sphinxclient.h
and in sphinx RPM is placed
rpm -ql sphinx |grep sphinxclient.h
/usr/share/sphinx/api/libsphinxclient/sphinxclient.h
I have
/usr/share/sphinx/api/libsphinxclient/include/sphinxclient.h -> ../sphinxclient.h

Reproduce code:
---------------
/usr/local/php/bin/phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626

./configure --with-php-config=/usr/local/php/bin/php-config --with-sphinx=/usr/share/sphinx/api/libsphinxclient/

Expected result:
----------------
configure exit without error

Actual result:
--------------
configure: error: wrong libsphinxclient version or lib not found

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-09-14 17:39 UTC] fuxa_kos at unihost dot cz
I don't see how add attachement here, full output from configure:

checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ANSI C... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /usr/local/php538
checking for PHP includes... -I/usr/local/php538/include/php -I/usr/local/php538/include/php/main -I/usr/local/php538/include/php/TSRM -I/usr/local/php538/include/php/Zend -I/usr/local/php538/include/php/ext -I/usr/local/php538/include/php/ext/date/lib
checking for PHP extension directory... /usr/local/php538/lib/php/extensions/no-debug-non-zts-20090626
checking for PHP installed headers prefix... /usr/local/php538/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
checking for gawk... gawk
checking for sphinx support... yes, shared
checking for libsphinxclient headers in /usr/share/sphinx/api/libsphinxclient/... found
/usr/share/sphinx/api/libsphinxclient///include/sphinxclient.h MY ok
checking for sphinx_create in -lsphinxclient... no
configure: error: wrong libsphinxclient version or lib not found
 [2011-09-18 02:34 UTC] at php dot net
>configure looking for 
>/usr/share/sphinx/api/libsphinxclient/include/sphinxclient.h
>and in sphinx RPM is placed
>rpm -ql sphinx |grep sphinxclient.h
>/usr/share/sphinx/api/libsphinxclient/sphinxclient.h

Yeah, conbfigure is looking for headers in $PREFIX/include and for the lib in $PREFIX/lib.
So make sure the lib is present there, no matter what kind of crazy path is used by the RPM package.
 [2011-10-25 16:09 UTC] fuxa_kos at unihost dot cz
libsphinxclient is required for build, but isn't part of shinx RPM (there are only headers, not libs). One course is build libsphinxclient from source

cd api/libsphinxclient && ./configure && make && sudo make install

after that, pecl install goes fine.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Nov 26 16:01:23 2020 UTC