php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59866 http_api.c:256: error: too few arguments to function 'php_ob_handler_used
Submitted: 2011-07-22 11:11 UTC Modified: 2012-02-21 20:18 UTC
From: mattsch at gmail dot com Assigned: felipe (profile)
Status: Closed Package: pecl_http (PECL)
PHP Version: 5.3.6 OS: Gentoo Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mattsch at gmail dot com
New email:
PHP Version: OS:

 

 [2011-07-22 11:11 UTC] mattsch at gmail dot com
Description:
------------
pecl-http-1.7.1 refuses to compile with either php 5.2 or php 5.3:

/var/tmp/portage/dev-php5/pecl-http-1.7.1/work/php5.3/http_api.c: In function
'_http_exit_ex':
/var/tmp/portage/dev-php5/pecl-http-1.7.1/work/php5.3/http_api.c:256: error:
too few arguments to function 'php_ob_handler_used'
/var/tmp/portage/dev-php5/pecl-http-1.7.1/work/php5.3/http_api.c:256: error:
too few arguments to function 'php_ob_handler_used'
make: *** [http_api.lo] Error 1
make: *** Waiting for unfinished jobs....


Additional information (environmenent, etc): https://bugs.gentoo.org/show_bug.cgi?id=368595

Expected result:
----------------
pecl-http compiles

Actual result:
--------------
pecl-http does not compile

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-08-23 06:34 UTC] bombadil at bosqueviejo dot net
Versi?n 1.7.0 works fine. You can write this:

pecl install pecl_http-1.7.0

to install it.
 [2011-10-12 21:22 UTC] felipe@php.net
Try a newer version.
 [2011-10-12 21:22 UTC] felipe@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: felipe
 [2011-10-12 21:31 UTC] mattsch at gmail dot com
Which version is it fixed in?  I don't see any new stable version.
 [2012-01-24 21:08 UTC] mabi at gentoo dot org
I'm sorry, why is this bug closed? It's perfectly reproducible, it's not fixed in 
the latest stable build. Please have a look again.
 [2012-02-21 20:18 UTC] mike@php.net
It should be fixed with the just released 1.7.2
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 08 00:05:52 2022 UTC