php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59850 Callback issues when inside method
Submitted: 2011-07-15 16:33 UTC Modified: 2017-04-01 19:34 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: troymccabe at gmail dot com Assigned:
Status: Wont fix Package: bbcode (PECL)
PHP Version: 5.3.6 OS: Windows XP (32)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: troymccabe at gmail dot com
New email:
PHP Version: OS:

 

 [2011-07-15 16:33 UTC] troymccabe at gmail dot com
Description:
------------
I created a wrapper class to wrap the creation and use of your 
extension. In the constructor, I'm creating the array of 
allowed tags and needed to use a callback.

If I move the array of tags outside the constructor and use it 
from global (not my final solution...ew.) the callbacks work 
fine. This doesn't appear to be an issue anywhere else.

I will poke around to see if I can remediate and rebuild from 
src.

(The only reason I'm using Windows is simply that's what we're 
issued...our production boxes are linux and I will test those 
later today).

Reproduce code:
---------------
http://troymccabe.com/bbcode.phps

Expected result:
----------------
string(4) "test" string(0) ""

Actual result:
--------------
Warning: bbcode_parse() [function.bbcode-parse]: function `!' 
is not callable in C:\www\...snip...\BBCode.class.php on line 
117

Warning: Invalid callback Array, array must have exactly two 
members in C:\www\...snip...\BBCode.class.php on line 117

Warning: bbcode_parse() [function.bbcode-parse]: function 
`Array' is not callable in C:\www\...snip...\BBCode.class.php 
on line 117

<ul>test</li>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 19:34 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 19:34 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2010, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Sep 20 11:01:26 2019 UTC