php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59841 Returns false when decrypting empty text.
Submitted: 2011-07-08 07:38 UTC Modified: 2015-02-11 18:49 UTC
From: margus at sipria dot fi Assigned:
Status: Not a bug Package: gnupg (PECL)
PHP Version: 5.3.5 OS: Ubuntu Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: margus at sipria dot fi
New email:
PHP Version: OS:

 

 [2011-07-08 07:38 UTC] margus at sipria dot fi
Description:
------------
Folloing code returns false when decrypting originally empty 
string:

        $gpg = new gnupg();
        $gpg->adddecryptkey($fingerprint, $passphrase);
        $output = $gpg->decrypt($data);

$output will be false, but $gpg->geterror() returns false 
also, so you can check that no error has happened. Output 
should be empty string?.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-02-11 18:49 UTC] jimjag@php.net
-Status: Open +Status: Not a bug
 [2015-02-11 18:49 UTC] jimjag@php.net
NAB
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Feb 16 03:01:24 2019 UTC