php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #59820 Can you add a tag to allow validation only
Submitted: 2011-06-18 11:18 UTC Modified: 2017-04-01 19:33 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: hiram_ at gmx dot net Assigned:
Status: Wont fix Package: bbcode (PECL)
PHP Version: Irrelevant OS: Solaris
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: hiram_ at gmx dot net
New email:
PHP Version: OS:

 

 [2011-06-18 11:18 UTC] hiram_ at gmx dot net
Description:
------------
We use your module for our forum. But since we disallow editing of post we want users to be notified if they forget closing tags etc.

Would it be possible to add a flag which disallows the auto correction and just throws a exception if the nesting etc is incorrect. It does not really matter if how this is done. Although it would be nice if it gives enough information see which tag is wrong (or at least which type of tag)

Reproduce code:
---------------
so given" [b]text[i]ddd[/b][/i] 

Expected result:
----------------
it would give some information saying your i tag is not closed yet.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 19:33 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 19:33 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2010, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Nov 17 00:01:34 2019 UTC