|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59806 phpize failed
Submitted: 2011-06-09 02:54 UTC Modified: 2016-06-20 03:44 UTC
Avg. Score:4.1 ± 0.8
Reproduced:10 of 10 (100.0%)
Same Version:3 (30.0%)
Same OS:0 (0.0%)
From: michael at bigmichi1 dot de Assigned: jon (profile)
Status: Wont fix Package: sasl (PECL)
PHP Version: 5.3.6 OS: Debian 6.0.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: michael at bigmichi1 dot de
New email:
PHP Version: OS:


 [2011-06-09 02:54 UTC] michael at bigmichi1 dot de
root@server:~# /var/www/pear/pecl -c /var/www/pear.conf 
install sasl-0.1.0
downloading sasl-0.1.0.tgz ...
Starting to download sasl-0.1.0.tgz (6,435 bytes)
.....done: 6,435 bytes
5 source files, building
running: phpize
Cannot find config.m4.
Make sure that you run '/usr/bin/phpize' in the top level 
source directory of the module

ERROR: `phpize' failed
root@server:~# /var/www/pear/pecl -c /var/www/pear.conf -V
PEAR Version: 1.9.3
PHP Version: 5.3.6-11
Zend Engine Version: 2.3.0
Running on: Linux server 2.6.32-5-amd64 #1 SMP Wed May 18 
23:13:22 UTC 2011 x86_64

Expected result:
should be installable through pecl command


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2015-01-20 22:05 UTC] fransecs at gmail dot com
Same error here, in my case it was due to multiarch support in Debian (1).

Adding "/x86_64-linux-gnu" to "/lib/" occurrences in config.m4 worked for me, here you are diff results:

diff config.m4 config.m4.OK 
<   AC_MSG_CHECKING(for SASL library in $SASL_DIR/lib)
>   AC_MSG_CHECKING(for SASL library in $SASL_DIR/lib/x86_64-linux-gnu)
<     if test -r $SASL_DIR/lib/lib$i.a; then
>     if test -r $SASL_DIR/lib/x86_64-linux-gnu/lib$i.a; then
<      AC_MSG_ERROR(Failed to locate a compatible SASL library in $SASL_DIR/lib)
>      AC_MSG_ERROR(Failed to locate a compatible SASL library in $SASL_DIR/lib/x86_64-linux-gnu)
<   LIBS="$LIBS -L$SASL_DIR/lib"
>   LIBS="$LIBS -L$SASL_DIR/lib/x86_64-linux-gnu"

 [2015-01-20 22:19 UTC] fransecs at gmail dot com
I also had updated sasl.c :

diff sasl.c sasl.c.OK
< function_entry sasl_functions[] = {
> zend_function_entry sasl_functions[] = {
 [2015-01-25 00:54 UTC]
-Assigned To: +Assigned To: jon
 [2016-06-20 03:43 UTC]
I'm no longer actively developing the sasl package.
 [2016-06-20 03:44 UTC]
-Status: Assigned +Status: Wont fix
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Jul 19 03:01:27 2024 UTC