php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59771 setCompressionQuality not enabled when GMagick version > 1.3.7
Submitted: 2011-05-17 16:18 UTC Modified: 2011-05-21 07:38 UTC
From: steve at twitpic dot com Assigned:
Status: Closed Package: gmagick (PECL)
PHP Version: 5.3.3 OS: Ubuntu 10.10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: steve at twitpic dot com
New email:
PHP Version: OS:

 

 [2011-05-17 16:18 UTC] steve at twitpic dot com
Description:
------------
setCompressionQuality is not being enabled, even when 
GraphicsMagick 1.3.7 or greater is installed on the system.

Reproduce code:
---------------
The constant GMAGICK_LIB_MASK is not getting defined correctly because on line 4570 of ./configure the $GRAPHICSMAGICK_VERSION_MASK is escaped-

$as_echo "#define GMAGICK_LIB_MASK \$GRAPHICSMAGICK_VERSION_MASK" >>confdefs.h

I know configure is being generated by phpize and config.m4, and I'm not 100% familiar with Autoconf but I think you need to use:

                AC_DEFINE_UNQUOTED(GMAGICK_LIB_MASK,$GRAPHICSMAGICK_VERSION_MASK,[Version mask for comparisons])

instead of

                AC_DEFINE(GMAGICK_LIB_MASK,$GRAPHICSMAGICK_VERSION_MASK,[Version mask for comparisons])

on line 39 of config.m4


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-05-21 07:38 UTC] vito@php.net
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at
http://pecl.php.net/get/gmagick

Thanks!
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Feb 17 10:01:25 2019 UTC