php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #5975 version of strip_tags() that specifies tags to strip (instead of tags to keep)
Submitted: 2000-08-04 20:51 UTC Modified: 2012-02-10 23:13 UTC
Votes:6
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: muhlig at us dot edu dot pl Assigned:
Status: Duplicate Package: Strings related
PHP Version: * OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: muhlig at us dot edu dot pl
New email:
PHP Version: OS:

 

 [2000-08-04 20:51 UTC] muhlig at us dot edu dot pl
Because I'd like to strip much less tags than I'd like to remain in the HTML file (and I suppose there are more people who would like such a feature) I'd suggest to accompany strip_tags with its counterpart:

string strip_tags (string str [, string allowable_tags])

in the following way (more or less):

string strip_some_tags (string str [, string not_allowable_tags])

or enhance strip_tags in order to allow only these tags which are not
allowed to exist in the resulting string.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-11-19 00:06 UTC] jani@php.net
-Package: Feature/Change Request +Package: Strings related -Operating System: Solaris 2.6 +Operating System: * -PHP Version: 4.0 +PHP Version: *
 [2011-02-26 20:40 UTC] jthijssen at noxlogic dot nl
This bug is a duplicate of #23723. A patch for this feature is added to that bug.
 [2012-02-10 23:13 UTC] johannes@php.net
-Status: Open +Status: Duplicate
 [2012-02-10 23:13 UTC] johannes@php.net
See bug #23723
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC