php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #59734 AMQPQueue constructor should set the queue name
Submitted: 2011-04-27 11:33 UTC Modified: 2011-09-08 02:15 UTC
From: kissifrot at gmail dot com Assigned:
Status: Closed Package: amqp (PECL)
PHP Version: 5.3.5 OS: Debian 6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
12 + 43 = ?
Subscribe to this entry?

 
 [2011-04-27 11:33 UTC] kissifrot at gmail dot com
Description:
------------
In the documentation if it is said about the queue_name parameter "The name of the queue to construct. If no queue name is specified, the broker will generate one".

The problem is that if we don't specify it, one is effectively generated, but we have no idea about it.

Would it be possible to add a class property or something equivalent to be able to retrieve the name of the current queue?



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-09-08 02:15 UTC] pdezwart at gmail dot com
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at
http://pecl.php.net/get/amqp

This has been fixed in v0.3.1
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri May 14 11:01:23 2021 UTC