php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #59678 Never enter in IfModule mod_php.c
Submitted: 2011-03-21 15:48 UTC Modified: 2011-03-30 09:49 UTC
From: fidojones at fidojones dot com Assigned: martynas (profile)
Status: Closed Package: htscanner (PECL)
PHP Version: 5.2.17 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fidojones at fidojones dot com
New email:
PHP Version: OS:

 

 [2011-03-21 15:48 UTC] fidojones at fidojones dot com
Description:
------------
As you described in example, never parse values if you put 
<IfModule mod_php.c> only with <IfModule mod_php5.c>

Reproduce code:
---------------
In the code the ifmodule is described as:

if (!strcasecmp(tok, "<IfModule")) {
TOKEN(tok, FILE_SEPARATOR);
parse = !strcmp(tok, MOD_PHP(PHP_MAJOR_VERSION) ">");

So you search for Ifmodule with PHP VERSION, for example 5:

This works, and parse values:

<IfModule mod_php5.c>

But in the example you put as:

This doesn't work, because never enter and not parse:

<IfModule mod_php.c>


Expected result:
----------------
Should work parse as: 

<IfModule mod_php5.c> and also as <IfModule mod_php.c>

Or modify the example and explain that values must be under:

<IfModule mod_php5.c>




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-03-30 09:49 UTC] martynas at venck dot us
Thanks for your report.

This is actually a documentation problem, since mod_php.c is not a valid module.

I didn't want to mention the explicit version in README, but since that caused some confusion, I've changed examples to mod_php5 in trunk.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Dec 16 18:01:26 2018 UTC