php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59657 no as key parsed as boolean, should be string
Submitted: 2011-03-08 09:55 UTC Modified: 2017-04-01 21:43 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: niklas dot laxstrom at gmail dot com Assigned:
Status: Wont fix Package: syck (PECL)
PHP Version: 5.3.2 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: niklas dot laxstrom at gmail dot com
New email:
PHP Version: OS:

 

 [2011-03-08 09:55 UTC] niklas dot laxstrom at gmail dot com
Description:
------------
It looks like the parser thinks that >no< is a boolean value, 
even when it's a key, not a value.

Reproduce code:
---------------
Feed the yaml below to spyc_load()


FILES:
  class: JavaFFS
  sourcePattern: %GROUPROOT%/freecol/trunk/FreeColMessages_%CODE%.properties
  definitionFile: %GROUPROOT%/freecol/trunk/FreeColMessages.properties
  targetPattern: freecol/FreeColMessages_%CODE%.properties
  codeMap:
    cs:    cs_CZ
    es:    es_ES
    it:    it_IT
    no:    nb_NO
    pl:    pl_PL
    sv:    sv_SE
    nl-be: nl_BE
    en-gb: en_GB
    en-us: en_US
    pt:    pt_PT
    pt-br: pt_BR
    zh-hans: zh_CN
<

Expected result:
----------------
--- yaml-test-syck-pecl.txt     2011-03-08 14:21:52.636297886 
+0000
+++ yaml-test-syck.txt  2011-03-08 14:21:52.384297881 +0000
@@ -82,6 +82,7 @@
           'es' => 'es_ES',
           'it' => 'it_IT',
           'nl-be' => 'nl_BE',
+          'no' => 'nb_NO',
           'pl' => 'pl_PL',
           'pt' => 'pt_PT',
           'pt-br' => 'pt_BR',


Actual result:
--------------
The whole entry with key 'no' is missing.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 21:43 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 21:43 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2008, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 03 10:01:24 2020 UTC