php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59645 Core dump when referencing previous blocks
Submitted: 2011-03-04 10:50 UTC Modified: 2017-04-01 21:44 UTC
From: mike dot squire at gmail dot com Assigned:
Status: Wont fix Package: syck (PECL)
PHP Version: 5.3.2 OS: RHEL 64bit x86
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mike dot squire at gmail dot com
New email:
PHP Version: OS:

 

 [2011-03-04 10:50 UTC] mike dot squire at gmail dot com
Description:
------------
Using '*' to reference a block previously defined with '&' causes core dumps and "zend_mm_heap corrupted" messages.

Reproduce code:
---------------
var_dump(syck_load("
a: &b
  c: x

d: *b
"));

Expected result:
----------------
array(2) {
  ["a"]=>
  array(1) {
    ["c"]=>
    string(1) "x"
  }
  ["d"]=>
  array(1) {
    ["c"]=>
    string(1) "x"
  }
}


Actual result:
--------------
Segmentation fault (core dumped)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 21:44 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 21:44 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2008, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 03 09:01:26 2020 UTC