php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #596 apache startup fails with php3 and sybase-ct loaded as a module.
Submitted: 1998-07-29 17:29 UTC Modified: 1998-08-23 15:16 UTC
From: stephen at pinebelt dot net Assigned:
Status: Closed Package: Sybase (dblib) related
PHP Version: 3.0.2a OS: RedHat Linux 5.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: stephen at pinebelt dot net
New email:
PHP Version: OS:

 

 [1998-07-29 17:29 UTC] stephen at pinebelt dot net
I installed apache and php3 exactly as described in the Quick Install section of the INSTALL file with one exception:

Where it says run ./configure --with-mysql, I used ./configure --with-sybase-ct=/opt/sybase.

After finishing the Quick Installation procedures, I typed "./apachectl start" from the /www/sbin directory and got: "./apachectl start: httpd could not be started".  When startup failed, I tried typing "./httpd" which gave me a Segmentation fault.

I compiled the software on RedHat Linux 5.1 and have Sybase CTLib 10.0.0 installed in /opt/sybase.  I'm sure that CTLib is installed properly because I access my database using sybperl and sqsh.

Just to make sure, I compiled php3 as an apache module without sybase-ct support, and everything worked fine.

Any ideas on why the sybase support is broken on my machine?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-08-23 15:16 UTC] zeev
Hmm, is that Sybase CTlib commercial? Because the one that's freely available, does not work on RH linux 5.x or
any other glibc2 system.  Sybperl might be working if you got a static binary compiled under a libc5 system.
If that's not the case, and you've regularly compiled Sybperl with your machine, and you actually have
glibc2 compatible CTlib - I'd appreciate access to that machine.  I never got to test the Sybase module under RH5.x.

final:  The free Sybase-CT library is not supposed to work
under RH 5.x.  It's not a PHP problem.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Nov 30 15:01:27 2020 UTC