php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59576 wrong path of files dumped from cache
Submitted: 2011-01-14 08:08 UTC Modified: 2016-08-31 16:00 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (50.0%)
From: wodud at gazeta dot pl Assigned: cmb (profile)
Status: Wont fix Package: APC (PECL)
PHP Version: 5.3.2 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
42 - 26 = ?
Subscribe to this entry?

 
 [2011-01-14 08:08 UTC] wodud at gazeta dot pl
Description:
------------
I opening some pages ( let say: http://localhost:33480/src/index2.php), so in apc cache is some file ( E:/path/src/index2.php ) . I do dump of hole cache (code below) , I clear cache and after that I load it from dump file (code below).

But now I've got in cache file with diffrent path ( E:\path\src\index2.php ), and if I would like to open previous page ( http://localhost:33480/src/index2.php ) php is looking for file ( E:/path/src/index2.php ) which is not in cache! So php will try to load it from disk.

For me it is crucial that it will work because I would like to keep whole pages in binary dump file.

PHP version:  5.3.5 - Windows
 apc
APC Support enabled 
Version  3.1.7-dev  
APC Debugging  Disabled  
MMAP Support  Disabled  
Locking type  File Locks  
Serialization Support  php  
Revision  $Revision: 307215 $  
Build Date  Jan 9 2011 18:56:21  

Directive Local Value Master Value 
apc.cache_by_default On On 
apc.canonicalize On On 
apc.coredump_unmap Off Off 
apc.enable_cli Off Off 
apc.enabled On On 
apc.file_md5 Off Off 
apc.file_update_protection 2 2 
apc.filters no value no value 
apc.gc_ttl 3600 3600 
apc.include_once_override Off Off 
apc.lazy_classes Off Off 
apc.lazy_functions Off Off 
apc.max_file_size 32M 32M 
apc.num_files_hint 1024 1024 
apc.preload_path no value no value 
apc.report_autofilter Off Off 
apc.rfc1867 Off Off 
apc.rfc1867_freq 0 0 
apc.rfc1867_name APC_UPLOAD_PROGRESS APC_UPLOAD_PROGRESS 
apc.rfc1867_prefix upload_ upload_ 
apc.rfc1867_ttl 3600 3600 
apc.serializer default default 
apc.shm_segments 1 1 
apc.shm_size 256M 256M 
apc.slam_defense On On 
apc.stat Off Off 
apc.stat_ctime Off Off 
apc.ttl 0 0 
apc.use_request_time On On 
apc.user_entries_hint 4096 4096 
apc.user_ttl 0 0 
apc.write_lock On On 



Reproduce code:
---------------
$r = apc_bin_dumpfile(null, null, "E:\b.out");
var_dump($r);

$r=apc_bin_loadfile("E:\b.out");
var_dump($r);


Expected result:
----------------
It dumps paths (key for cache) exactly as it was in cache.

Actual result:
--------------
The paths in dump file are changed / -> \ .

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-08-31 16:00 UTC] cmb@php.net
-Status: Open +Status: Wont fix -Assigned To: +Assigned To: cmb
 [2016-08-31 16:00 UTC] cmb@php.net
According to <https://bugs.php.net/69618>, APC support has been
discontinued in favor of OPcache, APCu, the session upload
progress API and WinCache. Therefore this request won't be
implemented.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Feb 28 19:01:24 2021 UTC