php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59572 apc.shm_segments setting ignored in MMAP mode in Unknown on line 0
Submitted: 2011-01-12 09:30 UTC Modified: 2011-05-21 04:57 UTC
Votes:5
Avg. Score:3.6 ± 1.0
Reproduced:4 of 5 (80.0%)
Same Version:2 (50.0%)
Same OS:1 (25.0%)
From: arild dot rokenes at gmail dot com Assigned:
Status: Wont fix Package: APC (PECL)
PHP Version: Trunk SVN-2011-01-12 (dev) OS: CentOS 5.5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: arild dot rokenes at gmail dot com
New email:
PHP Version: OS:

 

 [2011-01-12 09:30 UTC] arild dot rokenes at gmail dot com
Description:
------------
When setting apc.shm_segments=2 you get the following error when running PHP. 
"PHP Warning:  PHP Startup: apc.shm_segments setting ignored in MMAP mode in Unknown on line 0"

Also APC INFO shows only 1 segment.

PHP 5.3.5

Reproduce code:
---------------
Set apc.shm_segments=2 in apc.ini and run php from console.

Expected result:
----------------
Expect to see no errors.

Actual result:
--------------
PHP Warning:  PHP Startup: apc.shm_segments setting ignored in MMAP mode in Unknown on line 0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-01-13 17:17 UTC] kalle@php.net
Did you use --enable-apc-mmap when configuring APC?
 [2011-01-14 10:46 UTC] arild dot rokenes at gmail dot com
--enable-apc-mmap was used when configuring APC.
 [2011-05-21 04:57 UTC] jpauli@php.net
There are no segment to define when using mmap as this has no sense, though the error message.

Closing.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Mar 04 01:01:24 2021 UTC