php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59553 can't build due to missing class member
Submitted: 2010-12-31 10:43 UTC Modified: 2012-06-13 02:25 UTC
From: kontakt at jan-pieper dot info Assigned: jani (profile)
Status: Closed Package: v8js (PECL)
PHP Version: 5.3.3 OS: Ubuntu 10.10 (Maverick)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kontakt at jan-pieper dot info
New email:
PHP Version: OS:

 

 [2010-12-31 10:43 UTC] kontakt at jan-pieper dot info
Description:
------------
Tried to install v8js via pecl command line tool but the build fails due to missing class member.

PHP Installation:
-----------------
PHP 5.3.3-1ubuntu9.1 with Suhosin-Patch (cli) (built: Oct 15 2010 14:17:04) 
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with XCache v1.3.0, Copyright (c) 2005-2009, by mOo
    with Xdebug v2.1.0, Copyright (c) 2002-2010, by Derick Rethans

Reproduce code:
---------------
$ sudo pecl install v8js-beta

Expected result:
----------------
successful build

Actual result:
--------------
downloading v8js-0.1.2.tgz ...
Starting to download v8js-0.1.2.tgz (17,745 bytes)
......done: 17,745 bytes
8 source files, building
running: phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626
Please provide the installation prefix of libv8 [autodetect] : 
building in /var/tmp/pear-build-root/v8js-0.1.2
running: /tmp/pear/temp/v8js/configure --with-v8js
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
checking for PHP extension directory... /usr/lib/php5/20090626+lfs
checking for PHP installed headers prefix... /usr/include/php5
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... re2c
checking for re2c version... 0.13.5 (ok)
checking for gawk... gawk
checking for V8 Javascript Engine... yes, shared
checking for V8 files in default path... found in /usr
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking how to run the C++ preprocessor... g++ -E
checking for V8 version... 2.2.18
checking for a sed that does not truncate output... (cached) /bin/sed
checking for fgrep... /bin/grep -F
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking whether we are using the GNU C++ compiler... (cached) yes
checking whether g++ accepts -g... (cached) yes
checking how to run the C++ preprocessor... g++ -E
checking for objdir... .libs
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC -DPIC
checking if cc PIC flag -fPIC -DPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking if cc supports -c -o file.o... (cached) yes
checking whether the cc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking for ld used by g++... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking for g++ option to produce PIC... -fPIC -DPIC
checking if g++ PIC flag -fPIC -DPIC works... yes
checking if g++ static flag -static works... yes
checking if g++ supports -c -o file.o... yes
checking if g++ supports -c -o file.o... (cached) yes
checking whether the g++ linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
configure: creating ./config.status
config.status: creating config.h
config.status: executing libtool commands
running: make
/bin/bash /var/tmp/pear-build-root/v8js-0.1.2/libtool --mode=compile g++  -I. -I/tmp/pear/temp/v8js -DPHP_ATOM_INC -I/var/tmp/pear-build-root/v8js-0.1.2/include -I/var/tmp/pear-build-root/v8js-0.1.2/main -I/tmp/pear/temp/v8js -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/temp/v8js/v8js.cc -o v8js.lo
libtool: compile:  g++ -I. -I/tmp/pear/temp/v8js -DPHP_ATOM_INC -I/var/tmp/pear-build-root/v8js-0.1.2/include -I/var/tmp/pear-build-root/v8js-0.1.2/main -I/tmp/pear/temp/v8js -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/v8js/v8js.cc  -fPIC -DPIC -o .libs/v8js.o
/tmp/pear/temp/v8js/v8js.cc:100: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc:100: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc:100: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc: In function ?void zim_V8Js___construct(int, zval*, zval**, zval*, int)?:
/tmp/pear/temp/v8js/v8js.cc:569: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc: In function ?void zim_V8Js_executeString(int, zval*, zval**, zval*, int)?:
/tmp/pear/temp/v8js/v8js.cc:667: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc: In function ?void zim_V8Js_getPendingException(int, zval*, zval**, zval*, int)?:
/tmp/pear/temp/v8js/v8js.cc:748: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc: In function ?void php_v8js_persistent_zval_ctor(zval**)?:
/tmp/pear/temp/v8js/v8js.cc:770: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc: In function ?void php_v8js_persistent_zval_dtor(zval**)?:
/tmp/pear/temp/v8js/v8js.cc:783: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc: In function ?void zim_V8Js_registerExtension(int, zval*, zval**, zval*, int)?:
/tmp/pear/temp/v8js/v8js.cc:848: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc: In function ?void zim_V8Js_getExtensions(int, zval*, zval**, zval*, int)?:
/tmp/pear/temp/v8js/v8js.cc:876: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc: In function ?void php_v8js_create_exception(zval*, v8::TryCatch*)?:
/tmp/pear/temp/v8js/v8js.cc:1004: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc:1008: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc:1011: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc:1018: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc:1022: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc: In function ?void zim_V8JsException_getJsFileName(int, zval*, zval**, zval*, int)?:
/tmp/pear/temp/v8js/v8js.cc:1060: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc:1060: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc: In function ?void zim_V8JsException_getJsLineNumber(int, zval*, zval**, zval*, int)?:
/tmp/pear/temp/v8js/v8js.cc:1065: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc:1065: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc: In function ?void zim_V8JsException_getJsSourceLine(int, zval*, zval**, zval*, int)?:
/tmp/pear/temp/v8js/v8js.cc:1070: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc:1070: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc: In function ?void zim_V8JsException_getJsTrace(int, zval*, zval**, zval*, int)?:
/tmp/pear/temp/v8js/v8js.cc:1075: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc:1075: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc: In function ?int zm_startup_v8js(int, int)?:
/tmp/pear/temp/v8js/v8js.cc:1145: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc:1146: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc:1147: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc:1148: warning: deprecated conversion from string constant to ?char*?
/tmp/pear/temp/v8js/v8js.cc: At global scope:
/tmp/pear/temp/v8js/v8js.cc:1276: warning: deprecated conversion from string constant to ?char*?
/bin/bash /var/tmp/pear-build-root/v8js-0.1.2/libtool --mode=compile g++  -I. -I/tmp/pear/temp/v8js -DPHP_ATOM_INC -I/var/tmp/pear-build-root/v8js-0.1.2/include -I/var/tmp/pear-build-root/v8js-0.1.2/main -I/tmp/pear/temp/v8js -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/temp/v8js/v8js_convert.cc -o v8js_convert.lo
libtool: compile:  g++ -I. -I/tmp/pear/temp/v8js -DPHP_ATOM_INC -I/var/tmp/pear-build-root/v8js-0.1.2/include -I/var/tmp/pear-build-root/v8js-0.1.2/main -I/tmp/pear/temp/v8js -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/v8js/v8js_convert.cc  -fPIC -DPIC -o .libs/v8js_convert.o
/tmp/pear/temp/v8js/v8js_convert.cc: In function ?int v8js_to_zval(v8::Handle<v8::Value>, zval*, int)?:
/tmp/pear/temp/v8js/v8js_convert.cc:556: warning: deprecated conversion from string constant to ?char*?
/bin/bash /var/tmp/pear-build-root/v8js-0.1.2/libtool --mode=compile g++  -I. -I/tmp/pear/temp/v8js -DPHP_ATOM_INC -I/var/tmp/pear-build-root/v8js-0.1.2/include -I/var/tmp/pear-build-root/v8js-0.1.2/main -I/tmp/pear/temp/v8js -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/temp/v8js/v8js_methods.cc -o v8js_methods.lo
libtool: compile:  g++ -I. -I/tmp/pear/temp/v8js -DPHP_ATOM_INC -I/var/tmp/pear-build-root/v8js-0.1.2/include -I/var/tmp/pear-build-root/v8js-0.1.2/main -I/tmp/pear/temp/v8js -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/v8js/v8js_methods.cc  -fPIC -DPIC -o .libs/v8js_methods.o
/tmp/pear/temp/v8js/v8js_methods.cc: In function ?void _php_v8js_dumper(v8::Local<v8::Value>, int)?:
/tmp/pear/temp/v8js/v8js_methods.cc:93: error: ?class v8::Value? has no member named ?IsRegExp?
make: *** [v8js_methods.lo] Error 1
ERROR: `make' failed

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-12-31 10:49 UTC] jani@php.net
Your V8 version is quite old:

checking for V8 version... 2.2.18

Where did you install that from? I'll see if I can test this at some point, right now I lack time and server to do any testing. With V8 3.0.4 it should work fine, that's the latest I know.
 [2010-12-31 11:26 UTC] kontakt at jan-pieper dot info
I used http://v8.googlecode.com/svn/trunk to install v8.
 [2010-12-31 11:40 UTC] jani@php.net
But obviously configure picked up something else. Quite likely something that came with e.g. NodeJs. Make sure you have only one version installed in your system with "find / -name 'libv8*'" and that you install all header files of V8.
 [2012-06-13 02:24 UTC] felipe@php.net
Automatic comment from SVN on behalf of felipe
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=326137
Log: - Fixed build in 5.4+
- Fixed bug #59553 (can't build due to missing class member)
 [2012-06-13 02:25 UTC] felipe@php.net
-Status: No Feedback +Status: Closed
 [2012-06-13 02:25 UTC] felipe@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 19 07:01:23 2020 UTC