php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59552 Can't Build
Submitted: 2010-12-31 08:25 UTC Modified: 2015-03-13 15:03 UTC
Votes:4
Avg. Score:5.0 ± 0.0
Reproduced:4 of 4 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (25.0%)
From: arjen at thenextweb dot com Assigned: jani (profile)
Status: Closed Package: v8js (PECL)
PHP Version: 5.3.3 OS: Ubuntu 4.4.3-4ubuntu5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
23 + 20 = ?
Subscribe to this entry?

 
 [2010-12-31 08:25 UTC] arjen at thenextweb dot com
Description:
------------
ERROR: `make' failed

Expected result:
----------------
Build

Actual result:
--------------
downloading v8js-0.1.2.tgz ...
Starting to download v8js-0.1.2.tgz (17,745 bytes)
......done: 17,745 bytes
8 source files, building
running: phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626
Please provide the installation prefix of libv8 [autodetect] : /root/v8-read-only/
building in /var/tmp/pear-build-root/v8js-0.1.2
running: /var/tmp/v8js/configure --with-v8js=/root/v8-read-only/
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib
checking for PHP extension directory... /usr/lib64/php/modules
checking for PHP installed headers prefix... /usr/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... re2c
checking for re2c version... 0.13.5 (ok)
checking for gawk... gawk
checking for V8 Javascript Engine... yes, shared
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking how to run the C++ preprocessor... g++ -E
checking for V8 version... NONE
checking for a sed that does not truncate output... (cached) /bin/sed
checking for fgrep... /bin/grep -F
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking whether we are using the GNU C++ compiler... (cached) yes
checking whether g++ accepts -g... (cached) yes
checking how to run the C++ preprocessor... g++ -E
checking for objdir... .libs
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC -DPIC
checking if cc PIC flag -fPIC -DPIC works... yes
checking if cc static flag -static works... no
checking if cc supports -c -o file.o... yes
checking if cc supports -c -o file.o... (cached) yes
checking whether the cc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking for ld used by g++... /usr/bin/ld -m elf_x86_64
checking if the linker (/usr/bin/ld -m elf_x86_64) is GNU ld... yes
checking whether the g++ linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking for g++ option to produce PIC... -fPIC -DPIC
checking if g++ PIC flag -fPIC -DPIC works... yes
checking if g++ static flag -static works... no
checking if g++ supports -c -o file.o... yes
checking if g++ supports -c -o file.o... (cached) yes
checking whether the g++ linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
configure: creating ./config.status
config.status: creating config.h
config.status: executing libtool commands
running: make
/bin/sh /var/tmp/pear-build-root/v8js-0.1.2/libtool --mode=compile g++  -I. -I/var/tmp/v8js -DPHP_ATOM_INC -I/var/tmp/pear-build-root/v8js-0.1.2/include -I/var/tmp/pear-build-root/v8js-0.1.2/main -I/var/tmp/v8js -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib -I/root/v8-read-only//include  -DHAVE_CONFIG_H  -g -O2   -c /var/tmp/v8js/v8js.cc -o v8js.lo
libtool: compile:  g++ -I. -I/var/tmp/v8js -DPHP_ATOM_INC -I/var/tmp/pear-build-root/v8js-0.1.2/include -I/var/tmp/pear-build-root/v8js-0.1.2/main -I/var/tmp/v8js -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib -I/root/v8-read-only//include -DHAVE_CONFIG_H -g -O2 -c /var/tmp/v8js/v8js.cc  -fPIC -DPIC -o .libs/v8js.o
/var/tmp/v8js/v8js.cc:100: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc:100: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc:100: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc: In function ?void zim_V8Js___construct(int, zval*, zval**, zval*, int)?:
/var/tmp/v8js/v8js.cc:569: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc: In function ?void zim_V8Js_executeString(int, zval*, zval**, zval*, int)?:
/var/tmp/v8js/v8js.cc:667: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc: In function ?void zim_V8Js_getPendingException(int, zval*, zval**, zval*, int)?:
/var/tmp/v8js/v8js.cc:748: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc: In function ?void php_v8js_persistent_zval_ctor(zval**)?:
/var/tmp/v8js/v8js.cc:770: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc: In function ?void php_v8js_persistent_zval_dtor(zval**)?:
/var/tmp/v8js/v8js.cc:783: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc: In function ?void zim_V8Js_registerExtension(int, zval*, zval**, zval*, int)?:
/var/tmp/v8js/v8js.cc:848: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc: In function ?void zim_V8Js_getExtensions(int, zval*, zval**, zval*, int)?:
/var/tmp/v8js/v8js.cc:876: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc: In function ?void php_v8js_create_exception(zval*, v8::TryCatch*)?:
/var/tmp/v8js/v8js.cc:1004: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc:1008: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc:1011: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc:1018: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc:1022: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc: In function ?void zim_V8JsException_getJsFileName(int, zval*, zval**, zval*, int)?:
/var/tmp/v8js/v8js.cc:1060: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc:1060: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc: In function ?void zim_V8JsException_getJsLineNumber(int, zval*, zval**, zval*, int)?:
/var/tmp/v8js/v8js.cc:1065: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc:1065: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc: In function ?void zim_V8JsException_getJsSourceLine(int, zval*, zval**, zval*, int)?:
/var/tmp/v8js/v8js.cc:1070: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc:1070: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc: In function ?void zim_V8JsException_getJsTrace(int, zval*, zval**, zval*, int)?:
/var/tmp/v8js/v8js.cc:1075: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc:1075: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc: In function ?int zm_startup_v8js(int, int)?:
/var/tmp/v8js/v8js.cc:1135: error: ?PHP_V8_VERSION? was not declared in this scope
/var/tmp/v8js/v8js.cc:1145: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc:1146: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc:1147: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc:1148: warning: deprecated conversion from string constant to ?char*?
/var/tmp/v8js/v8js.cc: In function ?void zm_info_v8js(zend_module_entry*)?:
/var/tmp/v8js/v8js.cc:1231: error: ?PHP_V8_VERSION? was not declared in this scope
/var/tmp/v8js/v8js.cc: At global scope:
/var/tmp/v8js/v8js.cc:1276: warning: deprecated conversion from string constant to ?char*?
make: *** [v8js.lo] Error 1
ERROR: `make' failed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-12-31 08:27 UTC] arjen at thenextweb dot com
Updated version and OS
 [2010-12-31 08:32 UTC] jani@php.net
It's the configure failing to detect the V8 version:

  checking for V8 version... NONE

I'm checking this now..
 [2010-12-31 08:39 UTC] arjen at thenextweb dot com
It is version 2010-12-21: Version 3.0.4
 [2010-12-31 08:46 UTC] jani@php.net
Did you use some fancy scons options with V8?
 [2010-12-31 09:03 UTC] arjen at thenextweb dot com
I used 
scons arch=x64

Plain scons gives:

scons
scons: Reading SConscript files ...
scons: done reading SConscript files.
scons: Building targets ...
g++ -o obj/release/accessors.o -c -Wall -Werror -W -Wno-unused-parameter -Wnon-virtual-dtor -pedantic -m32 -O3 -fomit-frame-pointer -fdata-sections -ffunction-sections -ansi -fno-rtti -fno-exceptions -fvisibility=hidden -Wall -Werror -W -Wno-unused-parameter -Wnon-virtual-dtor -pedantic -m32 -O3 -fomit-frame-pointer -fdata-sections -ffunction-sections -ansi -DV8_TARGET_ARCH_IA32 -DENABLE_VMSTATE_TRACKING -DENABLE_LOGGING_AND_PROFILING -DENABLE_DEBUGGER_SUPPORT -Isrc src/accessors.cc
In file included from /usr/include/features.h:385,
                 from /usr/include/stdio.h:28,
                 from src/../include/v8stdint.h:33,
                 from src/../include/v8.h:41,
                 from src/v8.h:55,
                 from src/accessors.cc:28:
/usr/include/gnu/stubs.h:7:27: error: gnu/stubs-32.h: No such file or directory
scons: *** [obj/release/accessors.o] Error 1
scons: building terminated because of errors.
 [2012-07-24 17:01 UTC] sommertm at gmail dot com
This is happening to me as well, on OS X Lion. I built v8 version 3.12.15 with scons (no options). I'm getting the same result as arjen.

Is there any additional information I can provide to assist?
 [2013-02-08 18:21 UTC] box dot for dot postman at gmail dot com
This is happening to me as well, on OS X Mountain Lion. I built v8 version 3.15.11 with mac ports. I'm getting the same result as arjen.

Is there any additional information I can provide to assist?
 [2015-03-13 15:03 UTC] stesie@php.net
-Status: Assigned +Status: Closed
 [2015-03-13 15:03 UTC] stesie@php.net
Build on MacOS is now fixed.  Confirmed at least on Yosemite.
See https://github.com/preillyme/v8js/issues/97

Since this is pretty old, I'm just closing it now.  Please re-open or submit a new report, if the problem still persists with master branch (or the release about to be published)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Aug 15 18:01:26 2020 UTC