php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #5954 Informix can't reliably figure if a text result column is NULL
Submitted: 2000-08-04 08:18 UTC Modified: 2008-07-18 16:30 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: mlemos at acm dot org Assigned: danny (profile)
Status: Not a bug Package: Feature/Change Request
PHP Version: 4.0 Latest CVS (04/08/2000) OS: Linux RH 6
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mlemos at acm dot org
New email:
PHP Version: OS:

 

 [2000-08-04 08:18 UTC] mlemos at acm dot org
There is the ifx_nullformat to tell wether NULL are returned as empty
strings or a string that has the text "NULL" in it.  Either forms can be
valid result values for character string result columns. There needs to
be a better solution.

Suggestion:  make Informix support work more like Oracle support that
optionally does not set the entries of the result row array returned by
ifx_fetch_row.

This could be implemented with a new function for instance named
ifx_returnnullcolumns that would take an argument that would set a an
boolean option.  null columns would only be returned if this option is true
and that would be the default value to remain compatible with the current
PHP-Informix API.

Adding this new function would be a better solution than adding an extra
mode option to ifx_nullformat because it would be easier detect if this
option is available using the function_defined() function.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-04 17:22 UTC] mrobinso@php.net
Change to feature/change request.
 [2000-08-04 23:13 UTC] danny@php.net
Seems a reasonable request.

Introduce the PHP4 notion of "NULL" values for variables?

if (ifx_hasnulloption()) {
  ifx_nullformat(2);
}

Or do you prefer your proposal ?

???

Danny
---
  

 [2008-07-18 16:30 UTC] jani@php.net
Informix is now in PECL. Please submit any feature requests here:

http://pecl.php.net/package/informix
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Oct 17 01:03:35 2021 UTC