php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59510 Message properties are sent as string
Submitted: 2010-11-15 10:28 UTC Modified: 2012-11-18 22:17 UTC
From: Ezequiel dot golub at gmail dot com Assigned:
Status: Not a bug Package: stomp (PECL)
PHP Version: 5.3.2 OS: Ubuntu Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Ezequiel dot golub at gmail dot com
New email:
PHP Version: OS:

 

 [2010-11-15 10:28 UTC] Ezequiel dot golub at gmail dot com
Description:
------------
Stomp sends all of the message properties as strings, when the 
actual data type is other.

Reproduce code:
---------------
// PRODUCER
// .. set up stomp connection
$stomp->send($queue, 1, array('delay'=>90, 'openAfter'=> (int)(time() + 90)));

// CONSUMER
// .. set up stomp connection
$stomp->subscribe($queue ,array('selector' => 'openAfter > 1'));

Expected result:
----------------
We should receive the message sent by the producer

Actual result:
--------------
No message is received. After further inspection, the most 
likely cause is that the 'openAfter' parameter is sent as a 
string rather than a int. ActiveMQ selector do not evaluate 
string into numeric values when using selectors, so we cannot 
use selectors/properties while using this Stomp library. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-11-18 22:17 UTC] pierrick@php.net
This is not a bug, STOMP (Simple Text Oriented Messaging Protocol) is a text 
oriented protocol, everything will always be send as a string
 [2012-11-18 22:17 UTC] pierrick@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 23:03:34 2021 UTC