php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59502 configure file is absent in package solr-0.9.11
Submitted: 2010-11-09 10:51 UTC Modified: 2010-11-16 04:29 UTC
From: andreys at bintime dot com Assigned:
Status: Not a bug Package: solr (PECL)
PHP Version: 5.3.2 OS: gentoo
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: andreys at bintime dot com
New email:
PHP Version: OS:

 

 [2010-11-09 10:51 UTC] andreys at bintime dot com
Description:
------------
I know from documentation that I need to do such steps to install solr:
./configure
make && make install

but there are no ./configure file in package 0.9.11 that I loaded from http://pecl.php.net/get/solr
Could you help me?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-11-09 13:03 UTC] iekpo@php.net
You need to get into the directory and then run phpize before attempting to run configure

phpize
./configure
make
make install
 [2010-11-10 03:09 UTC] andreys at bintime dot com
Thanks. This helped. But I faced the new problem, when tried to do `make`:
solr-0.9.11 # make
/bin/sh /home/andrey/solr-0.9.11/libtool --mode=compile cc  -I. -I/home/andrey/solr-0.9.11 -DPHP_ATOM_INC -I/home/andrey/solr-0.9.11/include -I/home/andrey/solr-0.9.11/main -I/home/andrey/solr-0.9.11 -I/usr/lib64/php5/include/php -I/usr/lib64/php5/include/php/main -I/usr/lib64/php5/include/php/TSRM -I/usr/lib64/php5/include/php/Zend -I/usr/lib64/php5/include/php/ext -I/usr/lib64/php5/include/php/ext/date/lib -I/usr/include/libxml2  -DHAVE_CONFIG_H  -g -O2   -c /home/andrey/solr-0.9.11/php_solr.c -o php_solr.lo 
/home/andrey/solr-0.9.11/libtool: line 467: CDPATH: command not found
/home/andrey/solr-0.9.11/libtool: line 1152: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.6b, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6b
libtool: and run autoconf again.
make: *** [php_solr.lo] Error 63
 [2010-11-16 04:29 UTC] andreys at bintime dot com
Found the correct steps to install:
1) phpize
2) aclocal
3) autoreconf -fvi
4) ./configure
5) make
6) make test
7) make install
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 09:01:23 2020 UTC