php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59489 Fail to compile with Solaris Studio 12
Submitted: 2010-11-02 14:07 UTC Modified: 2012-10-06 09:18 UTC
From: jl_ewing at hotmail dot com Assigned:
Status: No Feedback Package: ssh2 (PECL)
PHP Version: 5.3.2 OS: Solaris 10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jl_ewing at hotmail dot com
New email:
PHP Version: OS:

 

 [2010-11-02 14:07 UTC] jl_ewing at hotmail dot com
Description:
------------
PHP 5.3.3 (not 5.3.2) with ssh2-0.11.0.

Added extension to ext php5.3.3/ext directory, renamed directory from ssh2-0.11.0 to sshs.  Rebuilt configuration script and added --with-ssh2=<path to libssh2.so>.

libssh is libssh2-1.2.6.

Compiling with Solaris Studio 12.2


Expected result:
----------------
I expect it to compile ext/ssh2/ssh2.lo

Actual result:
--------------
Error is

/bin/sh /opt/tool/source/php-5.3.3/libtool --silent --preserve-dup-deps --mode=compile cc  -Iext/ssh2/ -I/opt/tool/source/php-5.3.3/ext/ssh2/ -DPHP_ATOM_INC -I/opt/tool/source/php-5.3.3/include -I/opt/tool/source/php-5.3.3/main -I/opt/tool/source/php-5.3.3 -I/opt/tool/source/php-5.3.3/ext/date/lib -I/opt/tool/source/php-5.3.3/ext/ereg/regex -I/opt/app/p1clv1w1/include/libxml2 -I/opt/app/p1clv1w1/lib/include -I/opt/app/p1clv1w1/include -I/opt/app/p1clv1w1/include/freetype2 -I/opt/tool/source/php-5.3.3/ext/mbstring/oniguruma -I/opt/tool/source/php-5.3.3/ext/mbstring/libmbfl -I/opt/tool/source/php-5.3.3/ext/mbstring/libmbfl/mbfl -I/opt/app/p1clv1w1/include/mysql -I/opt/app/p1clv1w1/oracle/product/11.2.0/client_1/rdbms/public -I/opt/tool/source/php-5.3.3/ext/sqlite3/libsqlite -I/opt/app/p1clv1w1/include/pspell -I/opt/tool/source/php-5.3.3/TSRM -I/opt/tool/source/php-5.3.3/Zend  -xtarget=ultra3 -m64 -xO5 -I /opt/app/p1clv1w1/include -xcode=pic32 -I /opt/app/p1clv1w1/include/libxml2 -I /opt/app/p1clv1w1/include/glib-2.0 -I /opt/app/p1clv1w1/lib/glib-2.0 -I /opt/app/p1clv1w1/include/libcroco-0.6/libcroco -I /opt/app/p1clv1w1/include/ncursesw -I /opt/app/p1clv1w1/include/mysql -I /opt/app/p1clv1w1/include/unicode -D_POSIX_PTHREAD_SEMANTICS  -I/opt/app/p1clv1w1/include -xtarget=ultra3 -m64 -xO5 -xcode=pic32 -xmemalign=8s   -c /opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c -o ext/ssh2/ssh2.lo
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 52: only one storage class allowed
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 270: warning: assignment type mismatch:
        pointer to void "=" pointer to function(pointer to struct _LIBSSH2_SESSION {}, pointer to const char, int, pointer to pointer to void) returning void
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 277: warning: assignment type mismatch:
        pointer to void "=" pointer to function(pointer to struct _LIBSSH2_SESSION {}, int, pointer to const char, int, pointer to const char, int, pointer to pointer to void) returning void
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 284: warning: assignment type mismatch:
        pointer to void "=" pointer to function(pointer to struct _LIBSSH2_SESSION {}, pointer to const char, int, pointer to pointer to void) returning int
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 291: warning: assignment type mismatch:
        pointer to void "=" pointer to function(pointer to struct _LIBSSH2_SESSION {}, int, pointer to const char, int, pointer to const char, int, pointer to pointer to void) returning void
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 503: warning: argument #4 is incompatible with prototype:
        prototype: pointer to char : "/opt/tool/source/php-5.3.3/Zend/zend_API.h", line 360
        argument : pointer to const char
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 504: warning: argument #4 is incompatible with prototype:
        prototype: pointer to char : "/opt/tool/source/php-5.3.3/Zend/zend_API.h", line 360
        argument : pointer to const char
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 508: warning: argument #4 is incompatible with prototype:
        prototype: pointer to char : "/opt/tool/source/php-5.3.3/Zend/zend_API.h", line 360
        argument : pointer to const char
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 509: warning: argument #4 is incompatible with prototype:
        prototype: pointer to char : "/opt/tool/source/php-5.3.3/Zend/zend_API.h", line 360
        argument : pointer to const char
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 510: warning: argument #4 is incompatible with prototype:
        prototype: pointer to char : "/opt/tool/source/php-5.3.3/Zend/zend_API.h", line 360
        argument : pointer to const char
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 511: warning: argument #4 is incompatible with prototype:
        prototype: pointer to char : "/opt/tool/source/php-5.3.3/Zend/zend_API.h", line 360
        argument : pointer to const char
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 516: warning: argument #4 is incompatible with prototype:
        prototype: pointer to char : "/opt/tool/source/php-5.3.3/Zend/zend_API.h", line 360
        argument : pointer to const char
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 517: warning: argument #4 is incompatible with prototype:
        prototype: pointer to char : "/opt/tool/source/php-5.3.3/Zend/zend_API.h", line 360
        argument : pointer to const char
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 518: warning: argument #4 is incompatible with prototype:
        prototype: pointer to char : "/opt/tool/source/php-5.3.3/Zend/zend_API.h", line 360
        argument : pointer to const char
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 519: warning: argument #4 is incompatible with prototype:
        prototype: pointer to char : "/opt/tool/source/php-5.3.3/Zend/zend_API.h", line 360
        argument : pointer to const char
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 992: warning: argument #3 is incompatible with prototype:
        prototype: pointer to unsigned int : "/opt/tool/source/php-5.3.3/Zend/zend_hash.h", line 179
        argument : pointer to int
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 992: warning: argument #4 is incompatible with prototype:
        prototype: pointer to unsigned long : "/opt/tool/source/php-5.3.3/Zend/zend_hash.h", line 179
        argument : pointer to long
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 1033: warning: argument #2 is incompatible with prototype:
        prototype: pointer to const unsigned char : "/opt/app/p1clv1w1/include/libssh2_publickey.h", line 85
        argument : pointer to char
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 1033: warning: argument #4 is incompatible with prototype:
        prototype: pointer to const unsigned char : "/opt/app/p1clv1w1/include/libssh2_publickey.h", line 85
        argument : pointer to char
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 1045: warning: argument #1 is incompatible with prototype:
        prototype: pointer to void : "/opt/tool/source/php-5.3.3/Zend/zend_alloc.h", line 60
        argument : pointer to const char
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 1067: warning: argument #2 is incompatible with prototype:
        prototype: pointer to const unsigned char : "/opt/app/p1clv1w1/include/libssh2_publickey.h", line 97
        argument : pointer to char
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 1067: warning: argument #4 is incompatible with prototype:
        prototype: pointer to const unsigned char : "/opt/app/p1clv1w1/include/libssh2_publickey.h", line 97
        argument : pointer to char
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 1104: warning: argument #4 is incompatible with prototype:
        prototype: pointer to char : "/opt/tool/source/php-5.3.3/Zend/zend_API.h", line 361
        argument : pointer to const unsigned char
"/opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c", line 1105: warning: argument #4 is incompatible with prototype:
        prototype: pointer to char : "/opt/tool/source/php-5.3.3/Zend/zend_API.h", line 361
        argument : pointer to const unsigned char
cc: acomp failed for /opt/tool/source/php-5.3.3/ext/ssh2/ssh2.c
*** Error code 1
make: Fatal error: Command failed for target `ext/ssh2/ssh2.lo'


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-06-14 21:52 UTC] langemeijer@php.net
Can you confirm if this problem is still there when using more recent versions?
 [2012-06-14 21:52 UTC] langemeijer@php.net
-Status: Open +Status: Feedback
 [2012-10-06 09:18 UTC] langemeijer@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2012-10-06 09:18 UTC] langemeijer@php.net
-Status: Feedback +Status: No Feedback
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jun 19 18:01:23 2021 UTC