php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59482 functions disappear in cached scripts
Submitted: 2010-10-28 15:49 UTC Modified: 2015-04-01 23:23 UTC
From: paul dot moses at solutionsadvancing dot com Assigned:
Status: Not a bug Package: APC (PECL)
PHP Version: 5.3.2 OS: ubuntu
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: paul dot moses at solutionsadvancing dot com
New email:
PHP Version: OS:

 

 [2010-10-28 15:49 UTC] paul dot moses at solutionsadvancing dot com
Description:
------------
a script was returning an error that a developer defined function was missing.  after hours of debug, I turned off the cache and it worked fine.

since then I have repeated this experience.

the function is defined in an include that then includes the file that actually contains the function.  it seems that it is dropping the include.


Reproduce code:
---------------
require $_SERVER['DOCUMENT_ROOT']."/dynamic/common/lib/univ_func.php";

Expected result:
----------------
I expect it to include the file specified which declares the function(s).  I expect those functions to be able for use in the script.

Actual result:
--------------
No error about the include file not being found, but there is an error when the function(s)defined in the include file are called.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-10-28 22:17 UTC] paul dot moses at solutionsadvancing dot com
the bug disappeared once I changed
the apc.include_once_override=1 to 0.
 [2010-11-10 13:00 UTC] gopalv82 at yahoo dot com
apc.include_once_override is not necessary for 5.3.x

Please don't use it in 5.3.x
 [2015-04-01 23:23 UTC] cmb@php.net
-Status: Open +Status: Not a bug
 [2015-04-01 23:23 UTC] cmb@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Note that apc.include_once_override is marked as being experimental.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 17 17:03:36 2021 UTC