php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59474 Compilation error
Submitted: 2010-10-25 16:06 UTC Modified: 2012-06-12 19:45 UTC
From: marco dot miacci at bireme dot br Assigned: felipe (profile)
Status: Closed Package: yaz (PECL)
PHP Version: 5.3.2 OS: Linux vm01lnx 2.6.34.7-0.3-xen
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: marco dot miacci at bireme dot br
New email:
PHP Version: OS:

 

 [2010-10-25 16:06 UTC] marco dot miacci at bireme dot br
Description:
------------
A erro occours when I try pecl install yaz.

PHP 5.3.3
PECL version 5.3.3 (pear 5.3.3)

Installed Packages (using zypper)

php5-pear
yaz 
libyaz
re2c





Reproduce code:
---------------
# pecl install yaz
downloading yaz-1.0.14.tar ...
Starting to download yaz-1.0.14.tar (Unknown size)
..............done: 76,288 bytes
5 source files, building
running: phpize5
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626
path to YAZ installation? [autodetect] : 
building in /var/tmp/pear-build-root/yaz-1.0.14
running: /tmp/pear/temp/yaz/configure --with-yaz
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for a sed that does not truncate output... /usr/bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib
checking for PHP extension directory... /usr/lib/php5/extensions
checking for PHP installed headers prefix... /usr/include/php5
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
checking for gawk... gawk
checking for YAZ support... yes, shared
checking for yaz-config... NONE
configure: error: YAZ not found (missing NONE)
ERROR: `/tmp/pear/temp/yaz/configure --with-yaz' failed
vm01lnx:/home/marco.miacci # 

Expected result:
----------------
Sucefull yaz package instalation 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-03-16 04:08 UTC] midilair at gmail dot com
I have an error when I try pecl install yaz.
yaz version expect is 3.0.2 or later, I have 4.1.2

# yaz-config --version
4.1.2
# pecl install yaz
downloading yaz-1.0.14.tgz ...
Starting to download yaz-1.0.14.tgz (16,601 bytes)
......done: 16,601 bytes
5 source files, building
running: phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626

configure.in:3: warning: prefer named diversions
configure.in:3: warning: prefer named diversions
path to YAZ installation? [autodetect] : building in /var/tmp/pear-build-root/yaz-1.0.14
running: /tmp/pear/temp/yaz/configure --with-yaz
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib
checking for PHP extension directory... /usr/lib/php/modules
checking for PHP installed headers prefix... /usr/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... re2c
checking for re2c version... 0.13.5 (ok)
checking for gawk... gawk
checking for YAZ support... yes, shared
checking for yaz-config... /usr/bin/yaz-config
checking for YAZ version... configure: error: YAZ version 3.0.2 or later required.
ERROR: `/tmp/pear/temp/yaz/configure --with-yaz' failed
 [2011-03-16 04:46 UTC] adam at indexdata dot dk
YAZ 4.1.0 through 4.1.3 had a fault that prevented phpyaz's 
configure to locate it. Please upgrade to YAZ 4.1.4 or later.
 [2012-06-12 19:45 UTC] felipe@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: felipe
 [2012-06-12 19:45 UTC] felipe@php.net
Try a newer version.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jul 06 03:01:28 2020 UTC