php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59421 make: *** [collator/collator_class.lo] Error 1 ERROR: `make' failed
Submitted: 2010-09-15 04:14 UTC Modified: 2012-07-01 04:47 UTC
Votes:4
Avg. Score:3.5 ± 0.9
Reproduced:4 of 4 (100.0%)
Same Version:1 (25.0%)
Same OS:0 (0.0%)
From: pecl at zekerwaar dot nl Assigned: stas (profile)
Status: Not a bug Package: intl (PECL)
PHP Version: 5.3.2 OS: Mac OSX 10.6.4
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: pecl at zekerwaar dot nl
New email:
PHP Version: OS:

 

 [2010-09-15 04:14 UTC] pecl at zekerwaar dot nl
Description:
------------
# gcc -v
Using built-in specs.
Target: i686-apple-darwin10
Configured with: /var/tmp/gcc/gcc-5664~105/src/configure --
disable-checking --enable-werror --prefix=/usr --
mandir=/share/man --enable-languages=c,objc,c++,obj-c++ --
program-transform-name=/^[cg][^.-]*$/s/$/-4.2/ --with-
slibdir=/usr/lib --build=i686-apple-darwin10 --program-
prefix=i686-apple-darwin10- --host=x86_64-apple-darwin10 --
target=i686-apple-darwin10 --with-gxx-include-
dir=/include/c++/4.2.1
Thread model: posix
gcc version 4.2.1 (Apple Inc. build 5664)
# php -v
PHP 5.3.2 (cli) (built: Aug  7 2010 00:04:41) 
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend 
Technologies
# pecl install intl
downloading intl-1.1.1.tgz ...
Starting to download intl-1.1.1.tgz (142,269 bytes)
.....................done: 142,269 bytes
97 source files, building
running: phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626
Specify where ICU libraries and headers can be found 
[DEFAULT] : 
building in /var/tmp/pear-build-root/intl-1.1.1
running: /private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl/configure --with-icu-
dir=DEFAULT
checking for grep that handles long lines and -e... 
/usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for a sed that does not truncate output... 
/usr/bin/sed
checking for cc... cc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... i386-apple-darwin10.4.0
checking host system type... i386-apple-darwin10.4.0
checking target system type... i386-apple-darwin10.4.0
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php -
I/usr/include/php/main -I/usr/include/php/TSRM -
I/usr/include/php/Zend -I/usr/include/php/ext -
I/usr/include/php/ext/date/lib
checking for PHP extension directory... 
/usr/lib/php/extensions/no-debug-non-zts-20090626
checking for PHP installed headers prefix... 
/usr/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if 
you want to regenerate PHP parsers.
checking for gawk... no
checking for nawk... no
checking for awk... awk
checking if awk is broken... no
checking whether to enable internationalization support... 
yes, shared
checking for icu-config... /opt/local/bin/icu-config
checking for location of ICU headers and libraries... 
/opt/local
checking for ICU 3.4 or greater... found 4.3.4
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking how to run the C++ preprocessor... g++ -E
checking for ld used by cc... /usr/libexec/gcc/i686-apple-
darwin10/4.2.1/ld
checking if the linker (/usr/libexec/gcc/i686-apple-
darwin10/4.2.1/ld) is GNU ld... no
checking for /usr/libexec/gcc/i686-apple-darwin10/4.2.1/ld 
option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking how to run the C++ preprocessor... g++ -E
checking the maximum length of command line arguments... 
196608
checking command to parse /usr/bin/nm output from cc 
object... rm: conftest.dSYM: is a directory
ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking for dsymutil... dsymutil
checking for nmedit... nmedit
checking for -single_module linker flag... yes
checking for -exported_symbols_list linker flag... yes
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fno-common
checking if cc PIC flag -fno-common works... yes
checking if cc static flag -static works... no
checking if cc supports -c -o file.o... yes
checking whether the cc linker (/usr/libexec/gcc/i686-apple-
darwin10/4.2.1/ld) supports shared libraries... yes
checking dynamic linker characteristics... darwin10.4.0 dyld
checking how to hardcode library paths into programs... 
immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no

creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by g++... /usr/libexec/gcc/i686-apple-
darwin10/4.2.1/ld
checking if the linker (/usr/libexec/gcc/i686-apple-
darwin10/4.2.1/ld) is GNU ld... no
checking whether the g++ linker (/usr/libexec/gcc/i686-
apple-darwin10/4.2.1/ld) supports shared libraries... yes
checking for g++ option to produce PIC... -fno-common
checking if g++ PIC flag -fno-common works... yes
checking if g++ static flag -static works... no
checking if g++ supports -c -o file.o... yes
checking whether the g++ linker (/usr/libexec/gcc/i686-
apple-darwin10/4.2.1/ld) supports shared libraries... yes
checking dynamic linker characteristics... darwin10.4.0 dyld
(cached) (cached) checking how to hardcode library paths 
into programs... immediate
configure: creating ./config.status
config.status: creating config.h
running: make
/bin/sh /private/var/tmp/pear-build-root/intl-1.1.1/libtool 
--mode=compile cc -I/opt/local/include -I. -
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl -DPHP_ATOM_INC -
I/private/var/tmp/pear-build-root/intl-1.1.1/include -
I/private/var/tmp/pear-build-root/intl-1.1.1/main -
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl -I/usr/include/php -
I/usr/include/php/main -I/usr/include/php/TSRM -
I/usr/include/php/Zend -I/usr/include/php/ext -
I/usr/include/php/ext/date/lib -I/opt/local/include  -
DHAVE_CONFIG_H  -g -O2   -c 
/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl/php_intl.c -o php_intl.lo
mkdir .libs
 cc -I/opt/local/include -I. "-
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl" -DPHP_ATOM_INC -
I/private/var/tmp/pear-build-root/intl-1.1.1/include -
I/private/var/tmp/pear-build-root/intl-1.1.1/main "-
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl" -I/usr/include/php -
I/usr/include/php/main -I/usr/include/php/TSRM -
I/usr/include/php/Zend -I/usr/include/php/ext -
I/usr/include/php/ext/date/lib -I/opt/local/include -
DHAVE_CONFIG_H -g -O2 -c 
"/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl/php_intl.c"  -fno-common -DPIC 
-o .libs/php_intl.o
/bin/sh /private/var/tmp/pear-build-root/intl-1.1.1/libtool 
--mode=compile cc -I/opt/local/include -I. -
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl -DPHP_ATOM_INC -
I/private/var/tmp/pear-build-root/intl-1.1.1/include -
I/private/var/tmp/pear-build-root/intl-1.1.1/main -
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl -I/usr/include/php -
I/usr/include/php/main -I/usr/include/php/TSRM -
I/usr/include/php/Zend -I/usr/include/php/ext -
I/usr/include/php/ext/date/lib -I/opt/local/include  -
DHAVE_CONFIG_H  -g -O2   -c 
/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl/intl_error.c -o intl_error.lo
 cc -I/opt/local/include -I. "-
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl" -DPHP_ATOM_INC -
I/private/var/tmp/pear-build-root/intl-1.1.1/include -
I/private/var/tmp/pear-build-root/intl-1.1.1/main "-
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl" -I/usr/include/php -
I/usr/include/php/main -I/usr/include/php/TSRM -
I/usr/include/php/Zend -I/usr/include/php/ext -
I/usr/include/php/ext/date/lib -I/opt/local/include -
DHAVE_CONFIG_H -g -O2 -c 
"/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl/intl_error.c"  -fno-common -
DPIC -o .libs/intl_error.o
/bin/sh /private/var/tmp/pear-build-root/intl-1.1.1/libtool 
--mode=compile cc -I/opt/local/include -I. -
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl -DPHP_ATOM_INC -
I/private/var/tmp/pear-build-root/intl-1.1.1/include -
I/private/var/tmp/pear-build-root/intl-1.1.1/main -
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl -I/usr/include/php -
I/usr/include/php/main -I/usr/include/php/TSRM -
I/usr/include/php/Zend -I/usr/include/php/ext -
I/usr/include/php/ext/date/lib -I/opt/local/include  -
DHAVE_CONFIG_H  -g -O2   -c 
/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl/intl_convert.c -o 
intl_convert.lo
 cc -I/opt/local/include -I. "-
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl" -DPHP_ATOM_INC -
I/private/var/tmp/pear-build-root/intl-1.1.1/include -
I/private/var/tmp/pear-build-root/intl-1.1.1/main "-
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl" -I/usr/include/php -
I/usr/include/php/main -I/usr/include/php/TSRM -
I/usr/include/php/Zend -I/usr/include/php/ext -
I/usr/include/php/ext/date/lib -I/opt/local/include -
DHAVE_CONFIG_H -g -O2 -c 
"/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl/intl_convert.c"  -fno-common -
DPIC -o .libs/intl_convert.o
/bin/sh /private/var/tmp/pear-build-root/intl-1.1.1/libtool 
--mode=compile cc -I/opt/local/include -I. -
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl -DPHP_ATOM_INC -
I/private/var/tmp/pear-build-root/intl-1.1.1/include -
I/private/var/tmp/pear-build-root/intl-1.1.1/main -
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl -I/usr/include/php -
I/usr/include/php/main -I/usr/include/php/TSRM -
I/usr/include/php/Zend -I/usr/include/php/ext -
I/usr/include/php/ext/date/lib -I/opt/local/include  -
DHAVE_CONFIG_H  -g -O2   -c 
/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl/collator/collator.c -o 
collator/collator.lo
mkdir collator/.libs
 cc -I/opt/local/include -I. "-
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl" -DPHP_ATOM_INC -
I/private/var/tmp/pear-build-root/intl-1.1.1/include -
I/private/var/tmp/pear-build-root/intl-1.1.1/main "-
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl" -I/usr/include/php -
I/usr/include/php/main -I/usr/include/php/TSRM -
I/usr/include/php/Zend -I/usr/include/php/ext -
I/usr/include/php/ext/date/lib -I/opt/local/include -
DHAVE_CONFIG_H -g -O2 -c 
"/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl/collator/collator.c"  -fno-
common -DPIC -o collator/.libs/collator.o
/bin/sh /private/var/tmp/pear-build-root/intl-1.1.1/libtool 
--mode=compile cc -I/opt/local/include -I. -
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl -DPHP_ATOM_INC -
I/private/var/tmp/pear-build-root/intl-1.1.1/include -
I/private/var/tmp/pear-build-root/intl-1.1.1/main -
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl -I/usr/include/php -
I/usr/include/php/main -I/usr/include/php/TSRM -
I/usr/include/php/Zend -I/usr/include/php/ext -
I/usr/include/php/ext/date/lib -I/opt/local/include  -
DHAVE_CONFIG_H  -g -O2   -c 
/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl/collator/collator_class.c -o 
collator/collator_class.lo
 cc -I/opt/local/include -I. "-
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl" -DPHP_ATOM_INC -
I/private/var/tmp/pear-build-root/intl-1.1.1/include -
I/private/var/tmp/pear-build-root/intl-1.1.1/main "-
I/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl" -I/usr/include/php -
I/usr/include/php/main -I/usr/include/php/TSRM -
I/usr/include/php/Zend -I/usr/include/php/ext -
I/usr/include/php/ext/date/lib -I/opt/local/include -
DHAVE_CONFIG_H -g -O2 -c 
"/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl/collator/collator_class.c"  -
fno-common -DPIC -o collator/.libs/collator_class.o
/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl/collator/collator_class.c:92: 
error: duplicate ?static?
/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl/collator/collator_class.c:96: 
error: duplicate ?static?
/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl/collator/collator_class.c:101:
 
error: duplicate ?static?
/private/var/tmp/apache_mod_php/apache_mod_php-
53~1/Build/tmp/pear/temp/intl/collator/collator_class.c:107:
 
error: duplicate ?static?
make: *** [collator/collator_class.lo] Error 1
ERROR: `make' failed



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-09-15 16:35 UTC] stas at zend dot com
You really should be using PHP source intl for 5.3, not PECL intl. I'll try to add some protection there to make it explicit.
 [2010-09-20 00:22 UTC] i at walkinraven dot name
And adds some instructions into the PHP manual.
 [2010-09-20 03:45 UTC] i at walkinraven dot name
Try add this in php.ini:

extension=intl.so
 [2011-09-06 12:45 UTC] ellochka12 at hotmail dot com
Hi,
I was wondering if this issue has been fixed by now? The 
problem is that I am running into the same issue and I tried 
installations running these commands: "pecl install intl", 
"pear install pecl/intl", "brew install intl". I get the 
same error about "duplicate in `static`". Please advise... 
Are there any dependencies? Like php5-devel I heard needs to 
be installed beforehand, is it true? I also tried to follow 
your comments here and added "extension=intl.so", but then 
installation cannot proceed because php is not loading any 
more. I would appreciate any help on this...

Thank you!
 [2012-07-01 04:47 UTC] stas@php.net
-Status: Assigned +Status: Not a bug
 [2012-07-01 04:47 UTC] stas@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

5.3 and 5.4 include intl as part of the source, so --enable-intl shoud be used to 
compile it.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Feb 19 11:01:27 2020 UTC