php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59296 pecl install fails with `make`
Submitted: 2010-07-07 12:45 UTC Modified: 2011-05-15 03:44 UTC
From: trukin at gmail dot com Assigned:
Status: Wont fix Package: gearman (PECL)
PHP Version: 5.3.2 OS: Ubuntu 10.4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: trukin at gmail dot com
New email:
PHP Version: OS:

 

 [2010-07-07 12:45 UTC] trukin at gmail dot com
Description:
------------
Running

sudo pecl install channel://pecl.php.net/gearman-0.7.0


Fails with 

/tmp/pear/temp/gearman/php_gearman.c: In function 
?zm_startup_gearman?:
/tmp/pear/temp/gearman/php_gearman.c:4467: error: 
?GEARMAN_VERBOSE_NEVER? undeclared (first use in this 
function)
/tmp/pear/temp/gearman/php_gearman.c:4467: error: (Each 
undeclared identifier is reported only once
/tmp/pear/temp/gearman/php_gearman.c:4467: error: for each 
function it appears in.)
make: *** [php_gearman.lo] Error 1
ERROR: `make' failed


Reproduce code:
---------------
sudo pecl install channel://pecl.php.net/gearman-0.7.0

Expected result:
----------------
work

Actual result:
--------------
not work

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-07-27 19:43 UTC] david at hisel dot com
I had the same error on Ubuntu 10.04.

To recreate the error, I used apt-get to install the 
gearman-* and libgearman-* packages.  Then, I ran pecl 
install channel://pecl.php.net/gearman-0.7.0.

I did get it to work finally...
1. uninstall every gearman-* and libgearman-* package from 
apt-get.
2.  download gearmand source, and configure/make/make 
install
3.  downlaod gearman-0.7.0 source, and 
phpize/configure/make/make install

HTH.

.dave.
 [2010-08-30 18:03 UTC] jbelich at adicio dot com
I've also found that doing an apt-get -b source gearman also before doing the pecl install also clears up this compile issue. However, i'm using the gearman-developers ppa.
 [2010-08-30 22:08 UTC] trukin at gmail dot com
The only way to bypass this "bug" is to install the latest 
libgearman
 [2011-05-15 03:44 UTC] hradtke@php.net
Please upgrade libgearman if you are having this problem.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Nov 13 15:01:28 2019 UTC