php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59268 Undefined symbol
Submitted: 2010-06-16 19:32 UTC Modified: 2017-04-01 19:23 UTC
From: sergio at gruposinternet dot com dot br Assigned:
Status: Wont fix Package: amfext (PECL)
PHP Version: 5.2.13 OS: FreeBSD 7.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
42 + 13 = ?
Subscribe to this entry?

 
 [2010-06-16 19:32 UTC] sergio at gruposinternet dot com dot br
Description:
------------
The extension crashes with undefined symbol.

Suggested patch:

--- amfext-0.9.2/php_amf.h	2008-03-31 06:23:48.000000000 -0300
+++ amfext-0.9.2b/php_amf.h	2010-06-16 19:56:22.000000000 -0300
@@ -27,4 +27,11 @@
 extern zend_module_entry amf_module_entry;
 #define phpext_amf_ptr &amf_module_entry
 
+// Define Z_REFCOUNT_P for PHP 5.3.x compatibility
+// Original code stole from apc_zend.h (APC caching extension)
+#if PHP_VERSION_ID < 50300
+#define Z_REFCOUNT_P(pz)              (pz)->refcount
+#define Z_REFCOUNT_PP(ppz)            Z_REFCOUNT_P(*(ppz))
+#endif
+
 #endif


Reproduce code:
---------------
Compile the stock extension from ports (/usr/ports/www/pecl-amfext), install and try to use it.

Expected result:
----------------
Working extension.

Actual result:
--------------
Crash.

/libexec/ld-elf.so.1: /usr/local/lib/php/20060613/amf.so: Undefined symbol "Z_REFCOUNT_P"


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 19:23 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 19:23 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2010, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Feb 26 17:01:25 2020 UTC