php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59187 can not install
Submitted: 2010-05-02 12:28 UTC Modified: 2013-10-23 08:00 UTC
From: jjrp78 at gmail dot com Assigned:
Status: Not a bug Package: zip (PECL)
PHP Version: 5.3.2 OS: ubuntu 10.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jjrp78 at gmail dot com
New email:
PHP Version: OS:

 

 [2010-05-02 12:28 UTC] jjrp78 at gmail dot com
Description:
------------
PEAR Version: 1.9.0
PHP Version: 5.3.2-1ubuntu4

zip package wont compile/install. 




Reproduce code:
---------------
$ pecl install zip

Starting to download zip-1.10.2.tgz (236,912 bytes)

.....

/usr/include/php5/ext/standard/php_string.h:128: note: expected ?size_t *? but argument is of type ?unsigned int *?

Expected result:
----------------
successfully compile and install package

Actual result:
--------------
error message:

/usr/include/php5/ext/standard/php_string.h:128: note: expected ?size_t *? but argument is of type ?unsigned int *?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-05-02 13:17 UTC] pierre dot php at gmail dot com
Why don't you use the 5.3.2 zip extension? Which contains the same code than the latest pecl release.

Also please attach the full error log.
 [2013-10-23 08:00 UTC] remi@php.net
-Status: Open +Status: Not a bug
 [2013-10-23 08:00 UTC] remi@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

Zip extension is now included in php sources.

And latest 1.12.2 build with with php >= 5.3
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Apr 05 07:01:23 2020 UTC