php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5914 Probably it was a Cashing Problem
Submitted: 2000-08-02 04:04 UTC Modified: 2000-08-02 11:46 UTC
From: max at tocrawl dot com Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0.1 OS: x86 Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: max at tocrawl dot com
New email:
PHP Version: OS:

 

 [2000-08-02 04:04 UTC] max at tocrawl dot com
I runed two files, A - the html file with include() line of file B. When my script (file B) was finished and working properly, I accessed it from file A and everything was OK, then for some reason I decided to simply copy entirelly the file B and paste it into file A instead include(). It gived me an error at line 1, where was typed exactly NOTHING. the problem was persisting no matter what.

I tried to change browsers, computers, but it was not a problem of browser's cashing. I then changed the first line of the script to be a stupid function with an output and everithing started working properly...  

I though that it might have been a php cashing problem, as fare as I know php cashes HTML it outputs, so unless I change the first output php for some reason could not update it's cash...

Sorry, if the problem was purely mine and not PHP's, I'm not a great programmer, but I thought that you might like to know about it.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-02 11:46 UTC] waldschrott@php.net
Usually browser caching really has nothing to do with this. If you?re going to post a real bug, please include condensed sample code to reproduce this.

Thanks for your report, you seem to have solved that problem yourself.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Mar 03 03:01:24 2021 UTC