php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #59137 php_apc.dll for 5.2.13
Submitted: 2010-03-30 00:42 UTC Modified: 2011-03-28 05:30 UTC
Votes:8
Avg. Score:3.5 ± 0.9
Reproduced:4 of 4 (100.0%)
Same Version:1 (25.0%)
Same OS:1 (25.0%)
From: t_wiedmann at t-online dot de Assigned:
Status: Wont fix Package: APC (PECL)
PHP Version: 5.2.13 OS: Windows XP / Server 2003
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: t_wiedmann at t-online dot de
New email:
PHP Version: OS:

 

 [2010-03-30 00:42 UTC] t_wiedmann at t-online dot de
Description:
------------
Hi,

I need php_apc.dll binaries for PHP 5.2.13. On http://downloads.php.net/pierre/ the lastest version is 5.2.9.

Many thanks!

Thomas

Reproduce code:
---------------
I get problems with the current APC-Version. 

Actually I use this:

* Apache apache_2.2.14-win32-x86-no_ssl.msi
* php-5.2.13-Win32
* Zend Framework 1.5.2

anything work well, but if I enable this APC dll (5.2.9) Apache STOPs and I get this in error.log:

[Fri Mar 26 08:05:14 2010] [apc-error] Cannot redeclare class zend_registry

Looks like a problem with Zend Framework, but without APC anything work well.

php.ini:

[APC]
apc.enabled=1
apc.shm_segments=1
apc.optimization=0
apc.shm_size=128
apc.ttl=7200
apc.user_ttl=7200
apc.num_files_hint=1024
apc.enable_cli=0
apc.rfc1867=1
apc.mmap_file_mask="c:/Programme/SVEN/apc-temp/apc.XXXXXX"

Bug or feature ?


I move my projekt to a new server (both Windows XP Server 2003)

old:
* apache_2.2.4-win32-x86-no_ssl.msi
* php-5.2.3-Win32
* php_apc.dll (Version 5.2.1.1)
* Zend Framework 1.5.2

Work well!

same code on the new server failed

* Apache apache_2.2.14-win32-x86-no_ssl.msi
* php-5.2.13-Win32
* php_apc.dll (Version 5.2.9)
* Zend Framework 1.5.2

Hope this helps 

Thanks!
Thomas


Expected result:
----------------
php_apc.dll binaries for PHP 5.2.13


Actual result:
--------------
With the current php_apc.dll (PHP 5.2.9 / 3.019) Apache failed.

[Fri Mar 26 08:05:14 2010] [apc-error] Cannot redeclare class zend_registry

Looks like a problem with Zend Framework, but without APC anything work well. 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-05-20 08:57 UTC] kalle@php.net
Any DLL compiled for 5.2.x will work, since we keep binary compatibility for each branch
 [2010-05-21 03:19 UTC] t_wiedmann at t-online dot de
Thanks!

Thats nice for you, but I still get this problem an APC did'nt work for me.

Can anyone check this out?
Any other idea?

Regards
Thomas
 [2010-06-06 10:22 UTC] 5917739 at gmail dot com
I have the same problem with php_apc-3.0.19-5.2-Win32-VC6-x86.zip from http://downloads.php.net/pierre/.

with apc enabled, PHP reports many errors on require_once, and constant redeclaration.
 [2010-11-03 19:27 UTC] pierre dot php at gmail dot com
Fetch 3.1.5 here: http://windows.php.net/~pierre/
 [2010-12-09 02:32 UTC] t_wiedmann at t-online dot de
Hi,

the bug is still open I think...

I habe download from http://downloads.php.net/pierre/ 
this one:
----------------------------------------------------------------------
php_apc-3.1.5-5.2-vc6-x86.zip (2010-11-02 12:01 -0800)
MD5 (php_apc-3.1.5-5.2-vc6-x86.zip) = 3745937fc4e8002acf2ce0511be0dd02
----------------------------------------------------------------------

still in use: Win32 and PHP 5.2.13


Restart my apache I get this...
[...]
Notice: Unknown: 1. h->opened_path=[null] h->filename=[../index.php] in Unknown on line 0
Notice: Unknown: 2. h->opened_path=[..\index.php] h->filename=[../index.php] in Unknown on line 0
Notice: Unknown: apc_cache_make_file_entry: entry->data.file.filename is [..\index.php] in Unknown on line 0
Notice: Unknown: Inserting [..\index.php] in Unknown on line 0
[...]

Any idea?

with kind regards,
Thomas
 [2011-01-11 18:03 UTC] jmjt at lut dot fi
I have the same thing

Notice: Unknown: 1. h->opened_path=[null] h->filename=[/usr/share/phpMyAdmin/index.php] in Unknown on line 0

Notice: Unknown: 2. h->opened_path=[/usr/share/phpMyAdmin/index.php] h->filename=[/usr/share/phpMyAdmin/index.php] in Unknown on line 0

Notice: Unknown: apc_cache_make_file_entry: entry->data.file.filename is [/usr/share/phpMyAdmin/index.php] in Unknown on line 0

Notice: Unknown: Inserting [/usr/share/phpMyAdmin/index.php] in Unknown on line 0


APC 3.1.4 is the last version not producing that. 3.1.5+ does.
 [2011-01-23 01:46 UTC] bb_plus at hotmail dot com
php_apc-3.1.5-5.2-vc6-x86 from http://downloads.php.net/pierre/ causes the Apache service to crash and not exit correctly on shutdown exactly as with the PHP 5.3.2 version Bug #19836 described at: Http://pecl.php.net/bugs/bug.php?id=19836

pajoye wrote over there:

"Sounds like I found the problem (the mem protection is buggy, have to disable it, not used anyway), I will upload new builds later today."

Is it possible to apply the same fix to php_apc-3.1.5-5.2-vc6-x86 or even better to a DLL for PHP 5.2.17 containing the new APC version 3.1.7?
 [2011-03-07 22:11 UTC] b5901 at hotmail dot com
Same problem here.
 [2011-03-24 13:30 UTC] qianbc2007 at hotmail dot com
the same problem when I using APC 3.1.6,does it mean the APC can't work or just a notice information?
 [2011-03-25 07:48 UTC] pierre dot php at gmail dot com
I have to strongly suggest to move to 5.3. PHP 5.2 is not 
maintained anymore.

Keep using 3.1.5 if you can't upgrade. But I can't take care 
of 5.2 anymore.
 [2011-03-28 05:14 UTC] t_wiedmann at t-online dot de
Which version do I choose? Use PHP 5.2.x and Apache for ever?

[quote http://windows.php.net/download/]
If you are using PHP with Apache 1 or Apache2 from apache.org you need to use the VC6 versions of PHP

There are only VC9 Binaries for 5.3.x
There are only VC6 Binaries for 5.2.x
[/quote] 

So I have to choose 5.2.x,  but ...

[quote pierre.php@gmail.com]
I have to strongly suggest to move to 5.3. PHP 5.2 is not  
maintained anymore. 

Keep using 3.1.5 if you can't upgrade. But I can't take care  
of 5.2 anymore. 
[/quote]


What should I Do? Is this a joke?

with kind regards,
Thomas
 [2011-03-28 05:27 UTC] t_wiedmann at t-online dot de
I will search for Apache VC9 Binaries here
http://www.apachelounge.com/

with kind regards,
Thomas
 [2011-03-28 05:30 UTC] pierre dot php at gmail dot com
PHP 5.2 is not maintained anymore. That's a rather clear 
statement and by no mean a joke.

About using 5.2 forever, that's your choice. It is fairly 
easy to migrate 5.2 application to 5.3. We have been warning 
about 5.2 end of life for more than a year now.

5.3 VC9 builds as well as APC 5.3 VC9 are much more stable 
than 5.2 ever has been, and much faster too. It is more than 
required to do this step forward instead of relying on 
outdated softwares.
 [2011-09-30 12:03 UTC] anonymous at anonymo dot us
Pierre, we understand that php5.2 is old, but we dont live in a perfect world.

Could you maybe post somewhere the instructions on how to compile apc.dll ourselves? Or recommend some article?

Thank you
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Nov 25 14:01:23 2020 UTC