php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59097 dtrace fails to compile/install
Submitted: 2010-03-03 18:44 UTC Modified: 2017-04-01 19:57 UTC
From: kwoodle at aya dot yale dot edu Assigned:
Status: Wont fix Package: DTrace (PECL)
PHP Version: 5.3.0 OS: opensolaris
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kwoodle at aya dot yale dot edu
New email:
PHP Version: OS:

 

 [2010-03-03 18:44 UTC] kwoodle at aya dot yale dot edu
Description:
------------
pecl install dtrace fails for stable version (1.0.3). Also, make fails for svn version 1.0.4. Error is reported for dtrace script.

if test -f ./.libs/dtrace.o ; then \
		dtrace -G -s /export/home/kim/Downloads/dtrace/dtrace-1.0.4/php.d ./.libs/dtrace.o ; \
	else \
		dtrace -G -s /export/home/kim/Downloads/dtrace/dtrace-1.0.4/php.d dtrace.lo ; \
	fi
dtrace: failed to compile script /export/home/kim/Downloads/dtrace/dtrace-1.0.4/php.d: "/usr/lib/dtrace/mpi.d", line 70: failed to resolve type genunix`kthread_t * for identifier curthread: Module and program data models do not match
make: *** [dtrace-fixup] Error 1


Reproduce code:
---------------
pecl install dtrace

Expected result:
----------------
Successful compile/install

Actual result:
--------------
if test -f ./.libs/dtrace.o ; then \
		dtrace -G -s /export/home/kim/Downloads/dtrace/dtrace-1.0.4/php.d ./.libs/dtrace.o ; \
	else \
		dtrace -G -s /export/home/kim/Downloads/dtrace/dtrace-1.0.4/php.d dtrace.lo ; \
	fi
dtrace: failed to compile script /export/home/kim/Downloads/dtrace/dtrace-1.0.4/php.d: "/usr/lib/dtrace/mpi.d", line 70: failed to resolve type genunix`kthread_t * for identifier curthread: Module and program data models do not match
make: *** [dtrace-fixup] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-10-08 04:26 UTC] michael dot hase at edition-software dot de
This seems to be a problem with newer opensolaris releases, not the dtrace pecl module. At least on my box the workaround from http://www.mail-archive.com/on-discuss@opensolaris.org/msg00302.html results in a working dtrace php module. Just
gzip /usr/lib/dtrace/mpi.d
and compile again.
This is on opensolaris dev snv_b130. Remember that's not the last published release snv_b134. I refuse to update since b130 is stable enough for me and b134 has some bugs.

Michael
 [2017-04-01 19:57 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 19:57 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2005, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Sep 23 17:01:26 2019 UTC