php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59075 "Aborted" on Gmagick initiation
Submitted: 2010-02-18 11:04 UTC Modified: 2010-03-16 05:55 UTC
From: pencap at gmail dot com Assigned: vitoc (profile)
Status: Closed Package: gmagick (PECL)
PHP Version: 5.2.11 OS: RHEL 4 i386
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pencap at gmail dot com
New email:
PHP Version: OS:

 

 [2010-02-18 11:04 UTC] pencap at gmail dot com
Description:
------------
Using Zend Server CE (http://www.zend.com/products/server-ce/downloads) with PHP 5.2 installation.  Gmagick fails to even run, actually, simply crashes PHP.  Since Zend only provides binaries I cannot actually give a backtrace.

Running GraphicsMagick 1.3.10.  Attempted with 1.3.8 and 1.3.9.

Compilation Log:


Reproduce code:
---------------
use the PHP cli and simply type php.  It will abort.

Actual result:
--------------
# pecl install gmagick-beta
downloading gmagick-1.0.3b5.tgz ...
Starting to download gmagick-1.0.3b5.tgz (36,436 bytes)
..........done: 36,436 bytes
9 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
Please provide the prefix of GraphicsMagick installation [autodetect] : 
building in /var/tmp/pear-build-root/gmagick-1.0.3b5
running: /tmp/pear/temp/gmagick/configure --with-gmagick
checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ANSI C... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for PHP prefix... /usr/local/zend
checking for PHP includes... -I/usr/local/zend/include/php -I/usr/local/zend/include/php/main -I/usr/local/zend/include/php/TSRM -I/usr/local/zend/include/php/Zend -I/usr/local/zend/include/php/ext -I/usr/local/zend/include/php/ext/date/lib
checking for PHP extension directory... /usr/local/zend/lib/php_extensions
checking for PHP installed headers prefix... /usr/local/zend/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
checking for gawk... gawk
checking whether to enable the gmagick extension... yes, shared
checking GraphicsMagick configuration program... found in /usr/local/bin/GraphicsMagick-config
checking GraphicsMagick version... found version 1.3.10
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if cc static flag  works... yes
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC
checking if cc PIC flag -fPIC works... yes
checking if cc supports -c -o file.o... yes
checking whether the cc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no

creating libtool
appending configuration tag "CXX" to libtool
configure: creating ./config.status
config.status: creating config.h
running: make
/bin/sh /var/tmp/pear-build-root/gmagick-1.0.3b5/libtool --mode=compile cc  -I. -I/tmp/pear/temp/gmagick -DPHP_ATOM_INC -I/var/tmp/pear-build-root/gmagick-1.0.3b5/include -I/var/tmp/pear-build-root/gmagick-1.0.3b5/main -I/tmp/pear/temp/gmagick -I/usr/local/zend/include/php -I/usr/local/zend/include/php/main -I/usr/local/zend/include/php/TSRM -I/usr/local/zend/include/php/Zend -I/usr/local/zend/include/php/ext -I/usr/local/zend/include/php/ext/date/lib -I/usr/local/include/GraphicsMagick  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/temp/gmagick/gmagick_helpers.c -o gmagick_helpers.lo
mkdir .libs
 cc -I. -I/tmp/pear/temp/gmagick -DPHP_ATOM_INC -I/var/tmp/pear-build-root/gmagick-1.0.3b5/include -I/var/tmp/pear-build-root/gmagick-1.0.3b5/main -I/tmp/pear/temp/gmagick -I/usr/local/zend/include/php -I/usr/local/zend/include/php/main -I/usr/local/zend/include/php/TSRM -I/usr/local/zend/include/php/Zend -I/usr/local/zend/include/php/ext -I/usr/local/zend/include/php/ext/date/lib -I/usr/local/include/GraphicsMagick -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/gmagick/gmagick_helpers.c  -fPIC -DPIC -o .libs/gmagick_helpers.o
/bin/sh /var/tmp/pear-build-root/gmagick-1.0.3b5/libtool --mode=compile cc  -I. -I/tmp/pear/temp/gmagick -DPHP_ATOM_INC -I/var/tmp/pear-build-root/gmagick-1.0.3b5/include -I/var/tmp/pear-build-root/gmagick-1.0.3b5/main -I/tmp/pear/temp/gmagick -I/usr/local/zend/include/php -I/usr/local/zend/include/php/main -I/usr/local/zend/include/php/TSRM -I/usr/local/zend/include/php/Zend -I/usr/local/zend/include/php/ext -I/usr/local/zend/include/php/ext/date/lib -I/usr/local/include/GraphicsMagick  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/temp/gmagick/gmagick_methods.c -o gmagick_methods.lo
 cc -I. -I/tmp/pear/temp/gmagick -DPHP_ATOM_INC -I/var/tmp/pear-build-root/gmagick-1.0.3b5/include -I/var/tmp/pear-build-root/gmagick-1.0.3b5/main -I/tmp/pear/temp/gmagick -I/usr/local/zend/include/php -I/usr/local/zend/include/php/main -I/usr/local/zend/include/php/TSRM -I/usr/local/zend/include/php/Zend -I/usr/local/zend/include/php/ext -I/usr/local/zend/include/php/ext/date/lib -I/usr/local/include/GraphicsMagick -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/gmagick/gmagick_methods.c  -fPIC -DPIC -o .libs/gmagick_methods.o
/tmp/pear/temp/gmagick/gmagick_methods.c: In function `zim_gmagick_newimage':
/tmp/pear/temp/gmagick/gmagick_methods.c:3051: warning: passing arg 1 of `ap_php_snprintf' from incompatible pointer type
/bin/sh /var/tmp/pear-build-root/gmagick-1.0.3b5/libtool --mode=compile cc  -I. -I/tmp/pear/temp/gmagick -DPHP_ATOM_INC -I/var/tmp/pear-build-root/gmagick-1.0.3b5/include -I/var/tmp/pear-build-root/gmagick-1.0.3b5/main -I/tmp/pear/temp/gmagick -I/usr/local/zend/include/php -I/usr/local/zend/include/php/main -I/usr/local/zend/include/php/TSRM -I/usr/local/zend/include/php/Zend -I/usr/local/zend/include/php/ext -I/usr/local/zend/include/php/ext/date/lib -I/usr/local/include/GraphicsMagick  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/temp/gmagick/gmagick.c -o gmagick.lo
 cc -I. -I/tmp/pear/temp/gmagick -DPHP_ATOM_INC -I/var/tmp/pear-build-root/gmagick-1.0.3b5/include -I/var/tmp/pear-build-root/gmagick-1.0.3b5/main -I/tmp/pear/temp/gmagick -I/usr/local/zend/include/php -I/usr/local/zend/include/php/main -I/usr/local/zend/include/php/TSRM -I/usr/local/zend/include/php/Zend -I/usr/local/zend/include/php/ext -I/usr/local/zend/include/php/ext/date/lib -I/usr/local/include/GraphicsMagick -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/gmagick/gmagick.c  -fPIC -DPIC -o .libs/gmagick.o
/bin/sh /var/tmp/pear-build-root/gmagick-1.0.3b5/libtool --mode=compile cc  -I. -I/tmp/pear/temp/gmagick -DPHP_ATOM_INC -I/var/tmp/pear-build-root/gmagick-1.0.3b5/include -I/var/tmp/pear-build-root/gmagick-1.0.3b5/main -I/tmp/pear/temp/gmagick -I/usr/local/zend/include/php -I/usr/local/zend/include/php/main -I/usr/local/zend/include/php/TSRM -I/usr/local/zend/include/php/Zend -I/usr/local/zend/include/php/ext -I/usr/local/zend/include/php/ext/date/lib -I/usr/local/include/GraphicsMagick  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/temp/gmagick/gmagickdraw_methods.c -o gmagickdraw_methods.lo
 cc -I. -I/tmp/pear/temp/gmagick -DPHP_ATOM_INC -I/var/tmp/pear-build-root/gmagick-1.0.3b5/include -I/var/tmp/pear-build-root/gmagick-1.0.3b5/main -I/tmp/pear/temp/gmagick -I/usr/local/zend/include/php -I/usr/local/zend/include/php/main -I/usr/local/zend/include/php/TSRM -I/usr/local/zend/include/php/Zend -I/usr/local/zend/include/php/ext -I/usr/local/zend/include/php/ext/date/lib -I/usr/local/include/GraphicsMagick -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/gmagick/gmagickdraw_methods.c  -fPIC -DPIC -o .libs/gmagickdraw_methods.o
/bin/sh /var/tmp/pear-build-root/gmagick-1.0.3b5/libtool --mode=compile cc  -I. -I/tmp/pear/temp/gmagick -DPHP_ATOM_INC -I/var/tmp/pear-build-root/gmagick-1.0.3b5/include -I/var/tmp/pear-build-root/gmagick-1.0.3b5/main -I/tmp/pear/temp/gmagick -I/usr/local/zend/include/php -I/usr/local/zend/include/php/main -I/usr/local/zend/include/php/TSRM -I/usr/local/zend/include/php/Zend -I/usr/local/zend/include/php/ext -I/usr/local/zend/include/php/ext/date/lib -I/usr/local/include/GraphicsMagick  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/temp/gmagick/gmagickpixel_methods.c -o gmagickpixel_methods.lo
 cc -I. -I/tmp/pear/temp/gmagick -DPHP_ATOM_INC -I/var/tmp/pear-build-root/gmagick-1.0.3b5/include -I/var/tmp/pear-build-root/gmagick-1.0.3b5/main -I/tmp/pear/temp/gmagick -I/usr/local/zend/include/php -I/usr/local/zend/include/php/main -I/usr/local/zend/include/php/TSRM -I/usr/local/zend/include/php/Zend -I/usr/local/zend/include/php/ext -I/usr/local/zend/include/php/ext/date/lib -I/usr/local/include/GraphicsMagick -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/gmagick/gmagickpixel_methods.c  -fPIC -DPIC -o .libs/gmagickpixel_methods.o
/bin/sh /var/tmp/pear-build-root/gmagick-1.0.3b5/libtool --mode=link cc -DPHP_ATOM_INC -I/var/tmp/pear-build-root/gmagick-1.0.3b5/include -I/var/tmp/pear-build-root/gmagick-1.0.3b5/main -I/tmp/pear/temp/gmagick -I/usr/local/zend/include/php -I/usr/local/zend/include/php/main -I/usr/local/zend/include/php/TSRM -I/usr/local/zend/include/php/Zend -I/usr/local/zend/include/php/ext -I/usr/local/zend/include/php/ext/date/lib -I/usr/local/include/GraphicsMagick  -DHAVE_CONFIG_H  -g -O2   -o gmagick.la -export-dynamic -avoid-version -prefer-pic -module -rpath /var/tmp/pear-build-root/gmagick-1.0.3b5/modules  gmagick_helpers.lo gmagick_methods.lo gmagick.lo gmagickdraw_methods.lo gmagickpixel_methods.lo -Wl,-rpath,/usr/local/lib -L/usr/local/lib -lGraphicsMagickWand -Wl,-rpath,/usr/local/lib -L/usr/local/lib -lGraphicsMagick
cc -shared  .libs/gmagick_helpers.o .libs/gmagick_methods.o .libs/gmagick.o .libs/gmagickdraw_methods.o .libs/gmagickpixel_methods.o  -Wl,--rpath -Wl,/usr/local/lib -Wl,--rpath -Wl,/usr/local/lib -L/usr/local/lib /usr/local/lib/libGraphicsMagickWand.so -L/usr/X11R6/lib -L/usr/lib /usr/local/lib/libGraphicsMagick.so  -Wl,-rpath -Wl,/usr/local/lib -Wl,-rpath -Wl,/usr/local/lib -Wl,-soname -Wl,gmagick.so -o .libs/gmagick.so
creating gmagick.la
(cd .libs && rm -f gmagick.la && ln -s ../gmagick.la gmagick.la)
/bin/sh /var/tmp/pear-build-root/gmagick-1.0.3b5/libtool --mode=install cp ./gmagick.la /var/tmp/pear-build-root/gmagick-1.0.3b5/modules
cp ./.libs/gmagick.so /var/tmp/pear-build-root/gmagick-1.0.3b5/modules/gmagick.so
cp ./.libs/gmagick.lai /var/tmp/pear-build-root/gmagick-1.0.3b5/modules/gmagick.la
PATH="$PATH:/sbin" ldconfig -n /var/tmp/pear-build-root/gmagick-1.0.3b5/modules
----------------------------------------------------------------------
Libraries have been installed in:
   /var/tmp/pear-build-root/gmagick-1.0.3b5/modules

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------

Build complete.
Don't forget to run 'make test'.

running: make INSTALL_ROOT="/var/tmp/pear-build-root/install-gmagick-1.0.3b5" install
Installing shared extensions:     /var/tmp/pear-build-root/install-gmagick-1.0.3b5/usr/local/zend/lib/php_extensions/
running: find "/var/tmp/pear-build-root/install-gmagick-1.0.3b5" | xargs ls -dils
12849498   8 drwxr-xr-x  3 root root   4096 Feb 18 10:02 /var/tmp/pear-build-root/install-gmagick-1.0.3b5
12849535   8 drwxr-xr-x  3 root root   4096 Feb 18 10:02 /var/tmp/pear-build-root/install-gmagick-1.0.3b5/usr
12849536   8 drwxr-xr-x  3 root root   4096 Feb 18 10:02 /var/tmp/pear-build-root/install-gmagick-1.0.3b5/usr/local
12849537   8 drwxr-xr-x  3 root root   4096 Feb 18 10:02 /var/tmp/pear-build-root/install-gmagick-1.0.3b5/usr/local/zend
12849538   8 drwxr-xr-x  3 root root   4096 Feb 18 10:02 /var/tmp/pear-build-root/install-gmagick-1.0.3b5/usr/local/zend/lib
12849539   8 drwxr-xr-x  2 root root   4096 Feb 18 10:02 /var/tmp/pear-build-root/install-gmagick-1.0.3b5/usr/local/zend/lib/php_extensions
12849534 400 -rwxr-xr-x  1 root root 399130 Feb 18 10:02 /var/tmp/pear-build-root/install-gmagick-1.0.3b5/usr/local/zend/lib/php_extensions/gmagick.so

Build process completed successfully
Installing '/usr/local/zend/lib/php_extensions/gmagick.so'
install ok: channel://pecl.php.net/gmagick-1.0.3b5
configuration option "php_ini" is not set to php.ini location
You should add "extension=gmagick.so" to php.ini


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-02-18 22:37 UTC] pencap at gmail dot com
I've looked into this further, it seems to be a conflict with the given tidy.so extension.  Disabling the tidy.so extension then proves to allow php to execute again with gmagick installed.

Not sure where exactly the conflict is but this seems to solve it temporarily.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Oct 22 11:01:29 2019 UTC