php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59072 Configure errors on 64 bits architecture
Submitted: 2010-02-10 16:24 UTC Modified: 2012-05-25 12:57 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: wilfried dot loche at fr dot adp dot com Assigned: pierrick (profile)
Status: Closed Package: mqseries (PECL)
PHP Version: 5.2.9 OS: Linux (SUSE10 SP2)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: wilfried dot loche at fr dot adp dot com
New email:
PHP Version: OS:

 

 [2010-02-10 16:24 UTC] wilfried dot loche at fr dot adp dot com
Description:
------------
Hi Philippe,

I've commented the [Bug #14649], I put it as a bug for 64 bit architecture.

I have a 64 bit server (HP Proliant DL360 G5 / SUSE10
SP2
4 HT Intel(R) Xeon(R) E5345 @ 2.30GHz / 8 Go RAM)

Here is what I had to do to make it work... not good way, but it works!

1. sed -i "s/\$MQSERIES_DIR\/lib/\$MQSERIES_DIR\/lib64/g" 
2. Edit configure: add lib64 here:
  save_old_LDFLAGS=$LDFLAGS
  ac_stuff="
     -L$MQSERIES_DIR/lib64
  "
3. ./configure
4. edit Makefile, add lib64 here:
MQSERIES_SHARED_LIBADD = -Wl,-rpath,/opt/mqm/lib64 -L/opt/mqm/lib64
-lmqic

Can you add the standard --with-libdir=lib64 option
on configure? It would be a mess for me to give the above instructions for production team to install the mqseries module!

Thx for your support, I will perform tests and give you feedbacks,
Wilfried Loche



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-02-10 16:47 UTC] wilfried dot loche at fr dot adp dot com
Actually, only the first point is needed, the Makefile is fine with something like:

./configure --with-php-config=/ehc/fs1/softs/spms/php_robot/bin/php-config --with-libdir=lib64

Wilfried Loche
 [2010-06-08 07:24 UTC] davexs2020 at yahoo dot com
Hi Wilfried,

It seems I'm having the same issue with 64-bit RHEL5. Here's an excerpt of ./configure

-----------------------------------------------------------
checking for gawk... gawk
checking for mqseries support... yes, shared
checking for mqseries files in default path... found in /opt/mqm
checking for MQCONN in -lmqic... no
configure: error: wrong mqseries lib version or lib not found
-----------------------------------------------------------

Where would I insert the first point?

sed -i "s/\$MQSERIES_DIR\/lib/\$MQSERIES_DIR\/lib64/g"

Thanks for your help.

Regards,

Dave
 [2010-08-30 06:12 UTC] giovanni dot colombrita at intesasanpaolo dot com
Hi,
i'm trying to do the same on a z-linux suse 10sp2  on 390 architecture. the package i'm trying to use is: mqseries.0.11.0.tgz

got the same problem, and i've also been trying the solution you purposed
but nothing seems to work, or maybe a do something wrong.

for instance i substituted using the sed command lib with lib64, having this configure changes:

configure:     -L$MQSERIES_DIR/lib64
configure:    if test -n "$MQSERIES_DIR/lib64"; then
configure:  if test "$MQSERIES_DIR/lib64" != "/usr/$PHP_LIBDIR" && test "$MQSERIES_DIR/lib64" != "/usr/lib"; then
configure:  if test -z "$MQSERIES_DIR/lib64" || echo "$MQSERIES_DIR/lib64" | grep '^/' >/dev/null ; then
configure:    ai_p=$MQSERIES_DIR/lib64
configure:    ep_dir="`echo $MQSERIES_DIR/lib64|$SED 's%/*[^/][^/]*/*$%%'`"
configure:    ai_p="$ep_realdir/`basename \"$MQSERIES_DIR/lib64\"`"
configure:  if test -n "$MQSERIES_DIR/lib64"; then
configure:  if test "$MQSERIES_DIR/lib64" != "/usr/$PHP_LIBDIR" && test "$MQSERIES_DIR/lib64" != "/usr/lib"; then
configure:  if test -z "$MQSERIES_DIR/lib64" || echo "$MQSERIES_DIR/lib64" | grep '^/' >/dev/null ; then
configure:    ai_p=$MQSERIES_DIR/lib64
configure:    ep_dir="`echo $MQSERIES_DIR/lib64|$SED 's%/*[^/][^/]*/*$%%'`"
configure:    ai_p="$ep_realdir/`basename \"$MQSERIES_DIR/lib64\"`"
configure.in:dnl Support systems with system libraries in e.g. /usr/lib64

and also acc_stuff i corrected properly

the results launching configure is

checking for re2c... re2c
checking for re2c version... 0.13.5 (ok)
checking for gawk... gawk
checking for mqseries support... yes, shared
checking for mqseries files in default path... found in /opt/mqm
checking for MQCONN in -lmqic... no
configure: error: wrong mqseries lib version or lib not found

so i have not a chanche to have a working makefile

what could be still wrong?


thank you very much

G.Luca Colombrita
 [2012-05-25 12:57 UTC] pierrick@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: pierrick
 [2012-05-25 12:57 UTC] pierrick@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.

You can now use --with-libdir=lib64
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed May 22 19:01:32 2019 UTC