php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59042 APC not working
Submitted: 2010-01-23 06:12 UTC Modified: 2010-01-23 12:49 UTC
From: mihai at emma dot ro Assigned:
Status: Not a bug Package: APC (PECL)
PHP Version: 5.2.11 OS: CentOS
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
39 - 20 = ?
Subscribe to this entry?

 
 [2010-01-23 06:12 UTC] mihai at emma dot ro
Description:
------------
I have installed the APC last stable and last beta under php 5.2.12 running on apache.

The apc.php returns Uptime 0 minutes 

You can see the file at http://www.cnet.ro/apc.php
and if you need a phpinfo you can find it at
http://www.newlady.ro/phpinfo.php

Thank you!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-01-23 10:53 UTC] rasmus@php.net
Are you running PHP as an Apache module?  Show us your 
phpinfo.  APC doesn't work with regular CGI.
 [2010-01-23 10:55 UTC] mihai at emma dot ro
I did mention the phpinfo in the first post here.
http://www.newlady.ro/phpinfo.php

It is CGI/FastCGI
but from WHM it is set up as suPHP
 [2010-01-23 12:38 UTC] rasmus@php.net
Right, sorry, missed the phpinfo.  APC does not support suPHP 
CGI setups.  There is no real way for it to do so.  That 
architecture tears down everything after each request 
including the shared memory segment which is why you see 0 
uptime.  Using APC in that environment will actually slow you 
down as it has to create a new shared memory segment, compile 
and cache the script, and then tear everything down on each 
and every request.
 [2010-01-23 12:47 UTC] mihai at emma dot ro
Well, in this case, is there any possibility to set up PHP as apache module only for one of this instances, not for the whole server?
 [2010-01-23 12:49 UTC] rasmus@php.net
Sorry, this is not a support forum.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Jun 22 03:01:23 2021 UTC