php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59004 seterrormode causes segmentation fault
Submitted: 2009-12-23 05:11 UTC Modified: -
From: empire at adslgr dot com Assigned:
Status: Open Package: gnupg (PECL)
PHP Version: 5_3.1RC2 OS: Fedora
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: empire at adslgr dot com
New email:
PHP Version: OS:

 

 [2009-12-23 05:11 UTC] empire at adslgr dot com
Description:
------------
Segmentation fault when calling the seterrormessage method, using the OO way.

gnupg_seterrormode() function works correctly instead.

gpgme library 1.1.8

Reproduce code:
---------------
$gpg = new gnupg();
$gpg->seterrormode(gnupg::ERROR_EXCEPTION);


Expected result:
----------------
error mode changed correctly

Actual result:
--------------
Segmentation Fault

Patches

Add a Patch

Pull Requests

Add a Pull Request

 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC