php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58939 OpenSSL error when installing stomp via pecl
Submitted: 2009-11-07 12:47 UTC Modified: 2009-11-10 09:40 UTC
From: iekpo@php.net Assigned: pierrick (profile)
Status: Not a bug Package: stomp (PECL)
PHP Version: 5.3.0 OS: Ubuntu 8.04.3 LTS
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: iekpo@php.net
New email:
PHP Version: OS:

 

 [2009-11-07 12:47 UTC] iekpo@php.net
Description:
------------
OpenSSL error when installing stomp via pecl 

pecl install stomp-beta

downloading stomp-0.3.0.tgz ...
Starting to download stomp-0.3.0.tgz (16,322 bytes)
......done: 16,322 bytes
6 source files, building
WARNING: php_bin /usr/local/php/bin/php appears to have a suffix /bin/php, but config variable php_suffix does not match
running: phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626
OpenSSL install prefix (no to disable SSL support) [/usr] : 
building in /var/tmp/pear-build-iekpo/stomp-0.3.0
running: /usr/local/pear/temp/stomp/configure --with-openssl-dir=/usr
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... unsupported
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for PHP prefix... /usr/local/php
checking for PHP includes... -I/usr/local/php/include/php -I/usr/local/php/include/php/main -I/usr/local/php/include/php/TSRM -I/usr/local/php/include/php/Zend -I/usr/local/php/include/php/ext -I/usr/local/php/include/php/ext/date/lib
checking for PHP extension directory... /usr/local/php/lib/php/extensions/debug-zts-20090626
checking for PHP installed headers prefix... /usr/local/php/include/php
checking if debug is enabled... yes
checking if zts is enabled... yes
checking for re2c... re2c
checking for re2c version... invalid
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking whether to enable stomp support... yes, shared
checking OpenSSL dir for stomp... /usr
checking for pkg-config... /usr/bin/pkg-config
checking for OpenSSL version... >= 0.9.6
checking for CRYPTO_free in -lcrypto... no
configure: error: libcrypto not found!
ERROR: `/usr/local/pear/temp/stomp/configure --with-openssl-dir=/usr' failed


Reproduce code:
---------------
pecl install stomp-beta

Then use default installation options only


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-11-07 16:50 UTC] pierrick@php.net
libcrypto is part of the OpenSSL package which is required if you want to compile the stomp extension with SSL support.

Please install the libssl-dev ubuntu package and let me now if the problem persists.
 [2009-11-10 09:40 UTC] pierrick@php.net
Problem was due to a CFLAGS='-Werror' in user's variables.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Nov 29 19:03:12 2021 UTC