php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58932 Error when converting an image
Submitted: 2009-11-03 12:49 UTC Modified: 2009-11-12 12:38 UTC
From: justin dot hendrickson at gmail dot com Assigned:
Status: Not a bug Package: gmagick (PECL)
PHP Version: 5.2.6 OS: Ubuntu 9.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: justin dot hendrickson at gmail dot com
New email:
PHP Version: OS:

 

 [2009-11-03 12:49 UTC] justin dot hendrickson at gmail dot com
Description:
------------
When trying to convert a JPG to GIF, PHP crashes with an assertion error.

Reproduce code:
---------------
<?php
$gmagick = new Gmagick("/home/jhendric/Pictures/kittenBot.jpg");
$gmagick->setImageFormat("GIF");

header("Content-Type: image/gif");
echo $gmagick;


Expected result:
----------------
A GIF image

Actual result:
--------------
php: wand/magick-image.c:9096: MagickSetImageFormat: Assertion `wand->signature == 0xabacadabUL' failed.
Aborted


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-11-12 07:29 UTC] vito@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PECL.


Hi, which version of GraphicsMagick are you using?
 [2009-11-12 12:38 UTC] justin dot hendrickson at gmail dot com
It appears that the problem is that I had both the imagick and gmagick extensions enabled at the same time. As soon as I disabled the imagick extension it worked.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Apr 12 01:01:24 2021 UTC