php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58905 unable to compile/configure
Submitted: 2009-10-19 01:14 UTC Modified: 2015-08-31 02:08 UTC
Votes:4
Avg. Score:3.8 ± 0.8
Reproduced:3 of 3 (100.0%)
Same Version:1 (33.3%)
Same OS:1 (33.3%)
From: philip@php.net Assigned:
Status: Open Package: xdiff (PECL)
PHP Version: 5_3 SVN-2009-10-19 (dev) OS: Mac OS X 10.6 (10A432)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: philip@php.net
New email:
PHP Version: OS:

 

 [2009-10-19 01:14 UTC] philip@php.net
Description:
------------
I am able to compile version 1.4.1 (after applying the fix 
for bug #16566) but cannot compile 1.5.1 and receive this 
error:

----------
...
checking for xdl_set_allocator in -lxdiff... no
configure: error: your libxdiff version is too old
ERROR: `/private/tmp/xdiff/configure --with-
xdiff=/Users/philip/devel/xdiff' failed
----------

However, the latest version appears to be 0.23, and that's 
what's installed via:

- http://www.xmailserver.org/xdiff-lib.html.

There appears to be a problem in config.m4 from this patch:

- http://svn.php.net/viewvc?view=revision&revision=261915



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-11-09 05:40 UTC] mg at iceni dot pl
Could you send me (mg at iceni dot pl) config.log file created from ./configure command?
 [2012-06-11 13:58 UTC] felipe@php.net
Some update on this issue, Philip?
 [2012-06-11 13:58 UTC] felipe@php.net
-Status: Open +Status: Feedback
 [2013-02-18 00:35 UTC] pecl-dev at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
 [2013-02-25 10:11 UTC] tim at digicol dot de
I have the same problem (Mac OS X 10.8, PHP 5.3.22, libxdiff 0.23, PECL xdiff 
1.5.2).

I can provide my config.log file if anyone has the time to look at it.
 [2014-10-20 20:11 UTC] asphp at dsgml dot com
The reason for this error is that the test for xdl_set_allocator and xdl_rabdiff does not include the proper library path for xdiff.

In the previous test for xdl_diff the detected include and library path is included in the compiler arguments, but in these two tests that variable was not set.

If you are experiencing this issue you can comment out the tests in config.m4 As long as the test for xdl_diff succeeds everything will be fine when you actually compile it.
 [2015-08-11 18:46 UTC] rbrisita at hotmail dot com
Thank you! Commenting out with '#' worked for me.
 [2015-08-31 02:08 UTC] philip@php.net
-Status: No Feedback +Status: Open
 [2015-08-31 02:08 UTC] philip@php.net
Status->Open
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 18 19:01:27 2019 UTC