php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58868 v1.8+ will not compile with DB2 v9.5 Fix pack 1 or lower
Submitted: 2009-09-30 11:16 UTC Modified: 2010-04-19 03:09 UTC
From: matthewv at ca dot ibm dot com Assigned:
Status: Closed Package: ibm_db2 (PECL)
PHP Version: 5.2.10 OS: ALL
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: matthewv at ca dot ibm dot com
New email:
PHP Version: OS:

 

 [2009-09-30 11:16 UTC] matthewv at ca dot ibm dot com
Description:
------------
Due to the addition of constants for the SQLRowCount feature that are not present in older version of DB2 this driver will not compile on older version of DB2.

As there is no notification this looks like a code bug with the driver and thus is was vary confusing to debug the problem.

Workaround is to compile the 1.7.1 driver which is not preferable. 



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-10-07 06:49 UTC] abhargav at in dot ibm dot com
Hi,

Looks like a bug. Will try to fix it soon.

Regards,
Ambrish Bhargava
 [2010-02-05 06:16 UTC] abhargav at in dot ibm dot com
Hi,

I tried to compile v1.8.3 of IBM_DB2 with v95 FP1 of DB2 and got it done successfully.

Can you provide me the commands that you have used and also the error that you got?

Regards,
Ambrish Bhargava
 [2010-04-19 03:09 UTC] abhargav at in dot ibm dot com
Hi,

As the problem is not reproduced, hence closing the bug.

Regards,
Ambrish Bhargava
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Jan 17 04:01:23 2021 UTC